Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   Th-350 troubles (http://www.hotrodders.com/forum/th-350-troubles-170254.html)

Bonhorst 12-20-2009 06:41 PM

Th-350 troubles
 
I have TH-350 bolted to a 353 sbc (carb, no computer), latley the tranny has been "disengaging" i guess, when i stop, the enging is still running but i have to rev up to about 4000 to get it re-engage and go the fluid is at the full mark, and doesnt smell burnt at all. today i pulled out on to the road and gave it full throttle, it smoke the tires pretty good untill the engine started to bog down and sputter, then the tranny made a god awful noise that sounded like someone had just spun the wheel of fortune, so i pulled over, shifted to park did some inspecting, nothing was missing, the fluid was good, and the engine ran just fine, however when i tried to leave the scene, every gear acted like nuetral. i have no inspection cover on the flywheel so i can see the TC is still there and spinning (probably should fix that) any ideas as to where i should go from here? any info helps, thank you

Chris

eloc431962 12-20-2009 06:45 PM

And you are 100% its full of fluid ?

Cole

Bonhorst 12-20-2009 06:47 PM

yes, i checked right after

eloc431962 12-20-2009 06:53 PM

So does it do it when it is still cold, or after warm up.Or does it do it all the time.
Sounds like it may be the clutches.JMO
Crosley can help if he sees this post. :thumbup:
Cole

Bonhorst 12-20-2009 08:40 PM

usually only when its cold. i only drive it to work which is about a mile away, its never happend before when i was driving it around town. but now, like i said all gears have been converted to neurtal. You think a simple rebuild kit from summit will fix it, i dont have much experiance with auto trannies, but im a quick learner

T-bucket23 12-21-2009 05:02 PM

Noise is never good, you will need to pull it and have it looked at. I would bet if you drop the pan you will find broken parts. If you have a gauge you can check for pressure, if you have none you probably broke the pump or the TC went south.

eloc431962 12-21-2009 05:16 PM

Quote:

Originally Posted by T-bucket23
Noise is never good, you will need to pull it and have it looked at. I would bet if you drop the pan you will find broken parts. If you have a gauge you can check for pressure, if you have none you probably broke the pump or the TC went south.

Yep this is were i was heading, Drop the pan see if something is down in the pan, I have even seen the filters fall down from poor replacement. But Chet is right you will more than likely have to pull it and have it looked at .

Cole


All times are GMT -6. The time now is 08:55 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.