TH350 issues - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-26-2011, 08:09 PM
Registered User
 
Join Date: Jun 2011
Location: charleston s.c
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
TH350 issues

Hey all i got a trans issue wanna see what you guys think. is a 73 th350 my line pressures are very low 10psi at idel around 60 under load in drive. trans has a b&m shift kit w 1 check ball new torque converter new modulator valve w the red band around it. the question is am i looking at a bad front pump or an over haul??

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-26-2011, 10:39 PM
Registered User
 
Last photo:
Join Date: Aug 2007
Location: Florida
Posts: 176
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
if the presures are low across the board not just in any certain gear then you definatley have a pump pressure issue has any work been done internally to the trans? did this happen after the SK install?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-27-2011, 08:14 PM
Registered User
 
Join Date: Jun 2011
Location: charleston s.c
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
not sure of internal work. shift kit was installed wrong from previous owner.replaced kit w b&m kit car will move but have low line pressure in all gears.rpm has to be 3 to 4k for the trans to engage
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-27-2011, 08:35 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Morris update 9-28-2014
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,175
Wiki Edits: 1659

Thanks: 414
Thanked 107 Times in 103 Posts
Quote:
Originally Posted by chrisomega
not sure of internal work. shift kit was installed wrong from previous owner.replaced kit w b&m kit car will move but have low line pressure in all gears.rpm has to be 3 to 4k for the trans to engage

if 1 check ball is not installed near the inner modulator valve, main line pressure will be low in all ranges.
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-27-2011, 08:52 PM
Registered User
 
Join Date: Jun 2011
Location: charleston s.c
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
OK. the b&m kit only has one ck ball in it i put it in were the instructions say to place it. the valve body in my trans has one ck ball in it. got a picture of were this ball is supposed be located???
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
th350 issues jesso350 Transmission - Rearend 7 06-12-2010 12:32 PM
TH350 Issues terminator0723 Transmission - Rearend 6 05-25-2009 03:23 PM
Th350 Tranny swap DRIVE SHAFT ISSUES sugar ray Transmission - Rearend 10 05-04-2009 12:55 PM
Transmission swap: TH250 to TH350 Torque converter issues. 35oldstruck Transmission - Rearend 5 05-21-2008 04:43 PM
TH350 reverse issues DoubleVision Transmission - Rearend 2 12-08-2005 06:53 PM


All times are GMT -6. The time now is 09:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.