TH350 kickdown housing leaks - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-22-2006, 01:09 PM
54belair's Avatar
Registered User
 
Join Date: Jun 2006
Location: Utah
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
TH350 kickdown housing leaks

I have a TH350 in my '54 belair, and when I park on a hill (or my driveway!) where the nose is higher than the back, tranny fluid leaks out the hole where the kickdown cable goes into the tranny. I've replaced that "hold down" piece, replaced the rubber washer/gasket, and it still leaks. I'm not talking a couple drips either. If I let it sit for a night it will nearly drain the tranny. I've tried explaining it away as "sweat from all that horsepower" but nobody believes me anymore. Is this common with these tranny's? What's the fix? Any ideas will be appreciated. Thanks!

mac

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-22-2006, 02:39 PM
Registered User
 
Join Date: Nov 2005
Location: Duffield ,Va
Age: 67
Posts: 526
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by 54belair
I have a TH350 in my '54 belair, and when I park on a hill (or my driveway!) where the nose is higher than the back, tranny fluid leaks out the hole where the kickdown cable goes into the tranny. I've replaced that "hold down" piece, replaced the rubber washer/gasket, and it still leaks. I'm not talking a couple drips either. If I let it sit for a night it will nearly drain the tranny. I've tried explaining it away as "sweat from all that horsepower" but nobody believes me anymore. Is this common with these tranny's? What's the fix? Any ideas will be appreciated. Thanks!

mac
You must have a crack in the plastic part that goes into trans case or a crack in the case, when I put one of those o-rings or grommets in I always use a little silicone and let it set up possibly overnight before use.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.