th350 leaks only at highway speed - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-27-2012, 05:01 PM
StudebakerDean
 
Last photo:
Join Date: Apr 2011
Location: missouri
Posts: 92
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
th350 leaks only at highway speed

help, got an odd one to figure out. my th350 trans leaks at highway speed only. it spits enough fluid to cover the frame and when it hits the exhaust it smokes it smells bad.
trans is rebuilt, had new seals, and gaskets.it shifts and functions fine. it doesnt leak on the driveway, and theres no apparent leaking around town at low speeds.hell i wouldnt be asking if it just leaked, but the smoke is bad.

but dart out on the highway get up to 55 or so and the puffs of smoke start coming up between the bed and cab.

any ideas? ive done all i know to do, and took it to a trans shop who replaced gov cover, and rear seal. and still smoke...

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-27-2012, 07:26 PM
S10 Racer's Avatar
http://www.warsprints.com
 

Last journal entry: W.A.R. (Wingless Auto Racing) Sprint Car Racing
Last photo:
Join Date: Nov 2007
Location: At The Dirt Tracks
Age: 55
Posts: 1,901
Wiki Edits: 0

Thanks: 3
Thanked 65 Times in 58 Posts
Quote:
Originally Posted by Studedean
help, got an odd one to figure out. my th350 trans leaks at highway speed only. it spits enough fluid to cover the frame and when it hits the exhaust it smokes it smells bad.
trans is rebuilt, had new seals, and gaskets.it shifts and functions fine. it doesnt leak on the driveway, and theres no apparent leaking around town at low speeds.hell i wouldnt be asking if it just leaked, but the smoke is bad.

but dart out on the highway get up to 55 or so and the puffs of smoke start coming up between the bed and cab.

any ideas? ive done all i know to do, and took it to a trans shop who replaced gov cover, and rear seal. and still smoke...
Check and make sure the vent tube is not plugged.
Attached Thumbnails
Click image for larger version

Name:	TH350-vent.jpg
Views:	677
Size:	79.0 KB
ID:	64993  
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-27-2012, 07:42 PM
Prof. T. Soggmeyer's Avatar
Plan B
 
Last photo:
Join Date: Jul 2006
Location: below the snow above the fog
Posts: 162
Wiki Edits: 0

Thanks: 0
Thanked 5 Times in 5 Posts
So would you say it leaks only after it warms up? If so, I would also check vent tube.
Brad...
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-27-2012, 09:15 PM
joshp83's Avatar
owner of Prices Garage
 
Last photo:
Join Date: Jun 2011
Location: west virginia
Age: 31
Posts: 329
Wiki Edits: 0

Thanks: 0
Thanked 23 Times in 23 Posts
is it over full if is the dip stick the correct one if its over full it will vent at higher speeds check for cooler line restrictions worst case would be pump is worn very bad
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine runs hot at highway speed. kirkschopped67 Engine 23 09-12-2012 05:12 PM
Possible Cure for SBC running hot at highway speed 75gmck25 Engine 5 01-31-2011 07:03 AM
T-350 leaks... pump? wakawu Transmission - Rearend 10 12-21-2009 05:52 AM
SBC runs rough at highway speed gearhead77 Engine 5 04-19-2007 11:00 AM
TH350 kickdown housing leaks 54belair Transmission - Rearend 1 06-22-2006 02:39 PM


All times are GMT -6. The time now is 02:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.