TH350 Question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-09-2009, 10:28 AM
Registered User
 
Join Date: Apr 2009
Location: Statesville, NC
Posts: 16
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
TH350 Question

Im having an issue with my tranny shifting from 2nd to 3rd when I have it in manual 2nd. It usually shifts at around 4600rpm. I want to hold it for about 5500. I was told it sounds like a valve body problem. How do i remove the valve body? Is it as simple as unscrewing the screws and pulling it off? I thought about Putting a TCI manual valve body in the tranny. Anybody had any experience with those?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-09-2009, 12:34 PM
Registered User
 
Last photo:
Join Date: Apr 2007
Location: Seattle, Wa
Posts: 6,822
Wiki Edits: 0

Thanks: 4
Thanked 449 Times in 384 Posts
Quote:
Originally Posted by terminator0723
Im having an issue with my tranny shifting from 2nd to 3rd when I have it in manual 2nd. It usually shifts at around 4600rpm. I want to hold it for about 5500. I was told it sounds like a valve body problem. How do i remove the valve body? Is it as simple as unscrewing the screws and pulling it off? I thought about Putting a TCI manual valve body in the tranny. Anybody had any experience with those?
The stock valve body will cause an upshift regardless of selected position of the shift lever at a point where the governor is armed for the WOT upshift, this is normal OEM function. Only solution is a modified valve body and governor.

Bogie
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
th350 question 39chevykid Transmission - Rearend 2 09-25-2006 07:29 PM
Th350 question Jeeper426 Transmission - Rearend 9 09-06-2006 09:02 PM
Question: TH350 acting weird Mad_Max Transmission - Rearend 6 08-03-2006 08:50 PM
TH350 Manual Valve Question Pantload Transmission - Rearend 6 02-19-2006 01:48 PM
T-350 rebuild question Marcus Transmission - Rearend 3 07-01-2004 07:48 PM


All times are GMT -6. The time now is 12:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.