th350 troubles - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-18-2010, 02:10 PM
markzepp820's Avatar
Registered User
 
Last photo:
Join Date: Sep 2006
Location: Kokomo, IN
Posts: 155
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
th350 troubles

Hello, I have a non-lockup th350 trans and i have this leak that just won't go away & would greatly appreciate some advice. My leak is coming from the 1-2 accumulator cover. So i replaced the o-ring. The old one was bad... dried up, brittle and hard. Anywase after i replaced it, the leak stopped at the accumulator but started leaking out of the pressure test ports by the accum. I put teflon tape on the threaded plugs and still leaks. So i'm wondering if the pressure is to0 high in my trans... maybe bad pressure regulator? I just can't figure it out I even put quick-steel epoxy on the pressure port to the left of the accum. and it actually stopped leaking. I tried the same for the port to the right of the accum. but it still wants to leak. Any suggestions? thanks, Mark

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-18-2010, 11:33 PM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
Make sure someone hasn't over tightened the port plugs and cracked the case.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-28-2010, 10:32 PM
markzepp820's Avatar
Registered User
 
Last photo:
Join Date: Sep 2006
Location: Kokomo, IN
Posts: 155
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
th350 troubles

okay thanks
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
TH350 Troubles robins44 Transmission - Rearend 12 05-11-2009 10:54 AM
Th350 troubles BadBowtie_84 Transmission - Rearend 2 11-04-2008 01:58 PM
T-350 Rebuild Tech jakeshoe Transmission - Rearend 10 10-05-2008 04:58 PM
TH350 Troubles newbielike Transmission - Rearend 3 12-24-2007 05:54 PM
th350 troubles SlammedC10 Transmission - Rearend 6 12-13-2002 04:21 PM


All times are GMT -6. The time now is 02:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.