Th350 Valve Body Problems - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 11-13-2008, 08:28 PM
Registered User
Join Date: Nov 2008
Location: Santa Clara California
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Th350 Valve Body Problems

Well just recently rebuilt my TH350 and everything was working great until I installed my TCI manual valve body. I have reverse but no forward gears and my line pressure is super low. I guess the question I have is do I have to install anything from my OEM valve body into my TCI valve body because the terrible directions don't tell me. The part number is 321100. Thanks guys!

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 11-14-2008, 03:59 PM
Crosley's Avatar
Global Moderator
Last wiki edit: T-350 rebuild tech
Last journal entry: Morris update 03-22-2015
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,674
Wiki Edits: 1659

Thanks: 635
Thanked 188 Times in 170 Posts
In my opinion the instruction sheet is quite clear.

With the low pressure you report;

Did you plug the necessary holes as instructed?

Did you leave the vacuum modulator valve in place?

Have you called TCI?
Dont worry how old you are... it is the mileage on your body that adds up.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Correct way to set valves on sbc w/ solid flat tappit camshaft? Joshua Lee Engine 17 02-09-2011 05:55 PM
700R4 Why are the TCI manual valve body instructions so lousy? Bayley Transmission - Rearend 24 02-16-2009 12:49 PM
transbrake valve body problems?? eight90 Transmission - Rearend 3 09-10-2007 02:01 PM
valve bodies for th350? gilliganspl Transmission - Rearend 4 05-03-2004 03:26 PM
Manual Valve body Big86inthestixx Transmission - Rearend 2 12-12-2003 02:08 PM

All times are GMT -6. The time now is 12:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.