Is there still air in my system? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-26-2014, 11:47 AM
Registered User
 
Last photo:
Join Date: Sep 2010
Location: Pennsylvania
Posts: 16
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Is there still air in my system?

Changed the rack and pinion cause it was leaking pretty bad.. Now that it is on notice a notchy feel to it when I turn. With front of the car up (and running) you can actually see the wheels kind of twitch as the wheel is being turned. I've bled the system twice thinking it is air,but nothing helped.

Im wondering since the old rack was leaking for a while if it got low enough to do some damage to the pump? The steering is a little stiffer then I remeber. Just to add I don't hear and strange sounds from the pump. I can hear a little bit of a noise coming from the rack,but Its very minimal.
Thanks for your help!!
Jason

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-27-2014, 06:15 AM
454 Rattler's Avatar
NEVER SATISFIED !!
 
Last photo:
Join Date: Sep 2006
Location: Eagle River WI.
Age: 70
Posts: 897
Wiki Edits: 0

Thanks: 5
Thanked 34 Times in 33 Posts
Did you flush the system ? Also, bleeding the system can sometimes take a while. Raise the front-end and turn Lock to lock slowly AT LEAST 20 times. Watch the fluid in the pump for bubbles.

I went through this last summer. EVERY new piece except one hose turned out to be defective.

Good luck to you.


454 RATTLER
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-27-2014, 06:29 AM
Registered User
 
Last photo:
Join Date: Sep 2010
Location: Pennsylvania
Posts: 16
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 454 Rattler View Post
Did you flush the system ? Also, bleeding the system can sometimes take a while. Raise the front-end and turn Lock to lock slowly AT LEAST 20 times. Watch the fluid in the pump for bubbles.

I went through this last summer. EVERY new piece except one hose turned out to be defective.

Good luck to you.


454 RATTLER
Thanks for your reply. Did I flush the system? No. Everything is new except for the pump. Am I missing something here? Ive been letting it sit and turn the wheels every now and then with the front up and engine off. I noticed I did have some real small bubbles in the resivor so Ill still crank on it a while see what happens. I'm glad to hear I'm not the only one with this problem
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is shop air safe for a fresh air breathing system? 777funk Garage - Tools 15 04-18-2012 10:40 PM
My New Air System Workingwoods Garage - Tools 8 05-23-2008 07:25 PM
air in cooling system markiemyster Engine 5 03-04-2006 03:34 PM
Show off your homeade/ancient air compressor/air supply system! ChevelleSS_LS6 Garage - Tools 2 08-07-2005 07:39 PM
stealth cool air intake system for 55 Bel Air Berliner Bel Air Engine 9 11-30-2004 03:32 PM


All times are GMT -6. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.