thermostat question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-17-2010, 10:37 AM
mitmaks's Avatar
Member
 

Last journal entry: Grille
Last photo:
Join Date: Sep 2002
Location: Washington
Age: 31
Posts: 1,599
Wiki Edits: 0

Thanks: 4
Thanked 10 Times in 10 Posts
thermostat question

This oil heater I have quit working and I'm trying to fix it. Took it apart and there's not much to it. Just switch, thermostat and oil tank. I think that thermostat might be bad. This is thermostat
http://www.smallappliance.com/produc...6&shopBy=Brand
I'm checking it with multimeter and when I adjust thermostat to the left or right reading doesn't change. Does this mean thermostat is bad?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-17-2010, 12:32 PM
vicrod's Avatar
life is a ride
 

Last journal entry: 2014
Last photo:
Join Date: Nov 2005
Location: Telford, PA
Age: 72
Posts: 1,347
Wiki Edits: 0

Thanks: 0
Thanked 60 Times in 56 Posts
What type of "oil" heater is it?
Some electric "oil" heaters have a tank.
Oil fired heaters (oil burners) have an oil tank.
The thermostat in the link you posted is for an electric heater not an oil burner.
What meter scale are you using to test the thermostat?
Using the OHMS scale you will measure continuity across the 2 wires attached to the thermostat. The thermostat must be disconnected for this measurement.
when the thermostat (switch) closes the meter will indicate 0 ohms. When the switch opens the meter will indicate infinity.
You should also hear it click when you rotate the shaft past room temperature.

vicrod
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-17-2010, 01:09 PM
mitmaks's Avatar
Member
 

Last journal entry: Grille
Last photo:
Join Date: Sep 2002
Location: Washington
Age: 31
Posts: 1,599
Wiki Edits: 0

Thanks: 4
Thanked 10 Times in 10 Posts
This is the heater I have
http://www.amazon.com/DeLonghi-EW050.../dp/B0000DK2YK
There's range on thermostat 0-6. When at 0 it's off and then 1-6 it's on but reading doesn't change. I did take thermostat out to measure this.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-17-2010, 02:00 PM
vicrod's Avatar
life is a ride
 

Last journal entry: 2014
Last photo:
Join Date: Nov 2005
Location: Telford, PA
Age: 72
Posts: 1,347
Wiki Edits: 0

Thanks: 0
Thanked 60 Times in 56 Posts
It may not be possible to test the thermostat at room temperature. It will depend on what temperature the thermostat is measuring such as the oil temperature.
If possible connect the 2 wires together from the heater that were connected to the thermostat then plug in it in. If the heater works the thermostat is bad.
This is only a test as it is unsafe to operate the heater without the thermostat.
Don't get zapped..

vicrod
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-17-2010, 02:12 PM
mitmaks's Avatar
Member
 

Last journal entry: Grille
Last photo:
Join Date: Sep 2002
Location: Washington
Age: 31
Posts: 1,599
Wiki Edits: 0

Thanks: 4
Thanked 10 Times in 10 Posts
Not sure what was wrong but it works now.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
383 stroker 73monte Engine 11 05-07-2014 08:08 AM
350 chevy small block over heating? xxxtonyrusxxx@yahoo. Engine 37 09-27-2011 06:10 PM
supercharger.... 73monte Engine 16 07-24-2010 10:27 AM
Ignotion Set-ups Native Gearhead Engine 8 11-29-2003 01:20 PM
Hi All I just Joined, Questions Re:454 rebuild Gay-Shark Engine 8 11-29-2003 10:25 AM


All times are GMT -6. The time now is 07:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.