Ticking/chattering sound from sbc - Page 2 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #16 (permalink)  
Old 05-27-2013, 05:48 PM
Registered User
 
Last photo:
Join Date: Mar 2007
Location: Corinth, MS
Posts: 607
Wiki Edits: 0

Thanks: 0
Thanked 30 Times in 29 Posts
You typed "It is a hydraulic cam with rollertip lifters."
That's the reason I said what I did about swapping lifters.
Anyway, I'm sorry to say that this pic indicates that either your pushrods are too short, or the lifters are collapsing(doubt it), or the cam is going flat as the circular marks on the studs opposite the valves show where the rocker is contacting when the valve closes/lifter returns to cam base diameter.
http://i119.photobucket.com/albums/o...r/CIMG2097.jpg
That is unless they were made before you installed longer pushrods.
You need to check the rise of each lifter with a dial indicator registering on the outside edge of the lifter, or a similar method, to verify the cam lobes aren't going flat(as has been suggested by BOBCRMAN)before you do anything else IMO.
ssmonty

    Advertisement

Last edited by ssmonty; 05-27-2013 at 05:54 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17 (permalink)  
Old 05-27-2013, 06:01 PM
Landshark928's Avatar
FrankenPorsche
 
Last photo:
Join Date: Feb 2010
Location: Pensacola, Fl
Age: 45
Posts: 459
Wiki Edits: 0

Thanks: 0
Thanked 13 Times in 9 Posts
1. Pull valve covers with it running and verify source of sound. With covers on you are just guessing. I have seen rockers hit the oil baffle in the valve covers.

2. Is this a new bottom end as well? Sounds like a rod hitting the oil pan to me. Was the block clearanced correctly for the stroke? Might just need to pull the pan and use a ball peen hammer to dent it out a bit at the point of contact unless it's hitting the pan rails.
Reply With Quote Quick reply to this message
  #18 (permalink)  
Old 05-27-2013, 06:15 PM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,130
Wiki Edits: 0

Thanks: 25
Thanked 267 Times in 250 Posts
"I have seen rockers hit the oil baffle in the valve cover"

Or the dripper or side of the valve cover.. Common on BBC.

360 lbs. in. is high for a hyd flat tappet cam. Still need to know seat pressure.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ticking sound from Exhaust. Slammedsi Hotrodding Basics 3 04-09-2013 08:58 PM
1974 454 ticking sound Torque454 Engine 7 02-28-2011 04:09 PM
ticking sound sbc Chevy Hi-Po Engine 13 12-28-2005 12:02 PM
ticking sound from distributer Echofive Engine 2 04-05-2004 12:26 AM
ticking sound Lightspeed Engine 9 12-26-2002 11:34 PM


All times are GMT -6. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.