Timing - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-02-2010, 06:49 PM
George Humphrey's Avatar
Registered User
 

Last journal entry: '64 Buick Special
Last photo:
Join Date: Jun 2009
Location: Minneapolis, MN.
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Timing

I recently got my car going, it acted OK at first then it started backfiring and running like crap I took timing out and put some in, same thing, I have a Procomp box and mech advance distributor, SBC 350 Vortec, Holly 770 street avenger, any suggestions??

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-02-2010, 07:14 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,856
Wiki Edits: 5

Thanks: 20
Thanked 246 Times in 200 Posts
If your car has been sitting a long time, I would be looking at the fuel system.....junk in the carb, plugged fuel filter. bad gas etc
__________________
Ontario Rodders
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Distributor Tuning and Theory - Part 1 Rick WI Engine 35 04-26-2011 12:38 AM
Low buck 355 sbc not running correctly, wanting to much timing. ForceFed86 Engine 68 04-13-2011 12:35 PM
sbc timing question 350pano Engine 8 05-15-2009 10:30 AM
Timing Timing Timing bigcountry1009 Hotrodding Basics 6 01-20-2009 05:47 PM
Do I need vacuum advance? (Long Post) Chevy21 Engine 49 10-25-2007 12:51 PM


All times are GMT -6. The time now is 12:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.