timing\dist\or curve? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge> Introduce Yourself
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-08-2004, 02:13 AM
Registered User
 
Join Date: Aug 2004
Location: Bakersfeild Ca,
Age: 46
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
timing\dist\or curve?

I have a 72 Ford Coriour whith A 68 302 in it.Every time I try to hook up my vac\advance it would make a loud clacking noise with the rotation of the distributer.So one day I decided to take a look and I found a worn out spring.So I replaced it,and the noise went away.Now I cant get the thing to get out of its own way.Its fine at idle and low speed but when you put your foot into it .It pops and spits and looses power.It ran ok with the vacuum advance plugged up but bad gas milage.I tried adjusting the points and the timing nothing works.Could my distributor be off?The only other thing I can think of is I used the same springtention when I replaced the springs, or should it be heavy and lite! I wouldnt think that would cause that big of a problem.Hope you can help thanx. Hey guys and girls If I am in the wrong forum let me know [first- timer]How do you change forums?

    Advertisement

Last edited by Tony v; 08-08-2004 at 03:18 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-08-2004, 06:30 AM
aka Duke of URL
 
Last wiki edit: Finding vacuum leaks Last photo:
Join Date: Oct 2001
Location: Rockville, MD
Posts: 4,821
Wiki Edits: 1

Thanks: 0
Thanked 0 Times in 0 Posts
Arrow

It's obviously the wrong spring or the pivot/bearing assembly is worn on the breaker plates. You need to make certain the plates are good and if so get the correct spring(s) and/or have it recurved.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-08-2004, 10:11 AM
Registered User
 
Join Date: Aug 2004
Location: Bakersfeild Ca,
Age: 46
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Is the pivet bearing the brass looking thing on the the plate that when you slide it over the pin it touches it ? If this it is wobbled out.
Reply With Quote Quick reply to this message

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 01:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.