Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   Tips on C-4 Rebuild (http://www.hotrodders.com/forum/tips-c-4-rebuild-140244.html)

Arrowhead 06-12-2008 06:16 AM

Tips on C-4 Rebuild
 
I have rebuilt this 70 Mustang from the ground up, but I tried to cheat on the transmission and I lost. So the car is done and on the road, but puking trans fluid bad when it warms up. So I ordered a TCI rebuild kit and the cars is back up on stands so I can pull the the trans. I'm thinking theres a crack somewhere that opens up when it's hot. I can drive about 10 miles before it lets loose. Pump? Torque Converter? I have another spare that might be able steal parts from if I find something damaged.

My buddy Irelands Child has given me some pointers on doing the rebuild and I have a factory manual that covers it pretty good. But I'm all ears as this is the first automatic I've ever rebuilt. This is like the last frontier for me as I've done everything else from paint and body to engine rebuilding to interior to EFI, so I might as well face my fears and do a transmission now too.

Any help would be appreciated, thanks.

wildthing 06-12-2008 07:04 AM

my 68 cougar lesks heavyly , but that appears to be the front seal. i have another trans that iam trying to get swapped in.

Arrowhead 06-12-2008 07:25 PM

1 Attachment(s)
Got the tranny out and on the bench tonight. So far I don't see any evidence of where the leak might be. But I know for a fact it was literally pouring out of the front of the bellhousing while running in park after driving for a few miles. When it's cold, not bad at all.


http://www.hotrodders.com/forum/atta...chmentid=30571

Crosley 06-12-2008 08:24 PM

inspect the converter for leaks too. cracked hub, loose drain plug, cracks at the threaded studs for the flex plate.

:cool:

Arrowhead 06-13-2008 05:39 AM

I thought of that too, the manual has instructions on how to pressure test.

Irelands child 06-13-2008 07:08 AM

http://www.fordmuscle.com/forums/c4-...-version2.html

Did you have the input shaft in correctly - the short spline goes in transmission with the long in the converter?

Dave W

Irelands child 06-18-2008 09:14 AM

2 Attachment(s)
Confused yet ??? Or is it going well - they really are fairly simple.

You might want to consider a TCI servo kit - the C4 version look a little bit different as this is the C6 with my C4 next to it

Dave W


All times are GMT -6. The time now is 06:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.