Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   Touchy front brakes... (http://www.hotrodders.com/forum/touchy-front-brakes-12652.html)

Gearhead forever 02-19-2003 02:05 PM

Touchy front brakes...
 
We have a `98 E150 van at the shop. The front wheels keep locking up in the snow/ice. We've had it in several shops, but to no avail. They replaced the front pads, rotors, overhauled the calipers etc. This didn't solve the problem. The brake pedal acts more like an off/on switch, rather than a gradual valve. This thing stops on a dime in the dry. (better than any other truck in our fleet.)
The last straw was the other day when at a train crossing, the driver couldn't stop and banged into the barrier as the train was almost on them. I've never driven anything like it before. The mechanic at the dealer said it was naturally touchy, I say B.S., its not supposed to be that way. I don't care if this guy has 40 years experience, he's wrong. I'm wondering if its in the master cyl. or proportioning valve. It has rear ABS, which seems to be working fine. Does anyone have any insight to what it could be??? Help.

HalfOunce 02-19-2003 02:50 PM

it could be many things first i would check would be make sure the rear brakes are set up high enough assuming this has drum in the rear.
If u r like a lot of peeps that never use the brakes while backing up or never use your emergancy brake the rear will never adjust.
Thus leaving u with nothing more than front brakes.

Gearhead forever 02-19-2003 04:18 PM

I forgot to mention that both shops fully serviced the rear drum brakes. They even chamfered the shoes and pads. Oddly enough two mechanics at the dealer had opposing views. One said it was ok, one said it wasn't. This thing has locked up on several people on dry pavement also. We have a variety of makes and models that are driven by most of us, and that there are differences in makes, but it seems extremely touchy. The driver has also been in this truck for over a year.

HotRodMan 02-19-2003 05:09 PM

I had this same problem with my hot rod and it turned out that the master cylinder plunger was not coming back all the way when you let off on the brake pedal. As I drove the car each time you depressed the brake pedal you would build up a little pressure until the brakes would grab like you described. Try to see if you can adjust the pedal so that there is just a little play (about 1/8 inch) between the time you push the brake pedal and the rod starts moving in the master cylinder. Hard to explain, but I hope you can see what I mean.

Gearhead forever 02-22-2003 11:51 AM

Thanks for the tips, I was starting to suspect the master cyl as well. I'll check it out.

Phat 02-25-2003 01:15 PM

I fixed and older f-250 with and alum master cyl also by repalcing the master. It seems someone had put it in a vise at one time and made the bore oval.


All times are GMT -6. The time now is 10:43 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.