Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Electrical (http://www.hotrodders.com/forum/electrical/)
-   -   TPS test parameters (http://www.hotrodders.com/forum/tps-test-parameters-215418.html)

stk90f150 02-25-2012 09:24 PM

TPS test parameters
 
I have a 1990 F150, 5.8L w/auto. I would like check the TPS voltages to see that they are as they should be but I do not know what the readings are supposed to be. And, also which colored wire to poke to test them. The idle rolls and truck shifts at 3900-4000, full trottle. Don't believe trottle is opening all the way, Thank You !

LATECH 02-26-2012 06:27 AM

Chances are , if the TPS has a problem it would illuminate the check engine light.
If the check engine light is on , scan it for codes.Repair as instructed in the service manual.
The throttle not opening all the way would not be a TPS problem. You should be checking the throttle cable adjustment, or the cable itself to see if it has a problem.Maybe the thottle plate has an issue, disconnect the cables and see if it opens fully to check.
An AOD in that truck will have a throttle valve cable that needs to be properly adjusted to shift correctly, also if not correctly setup will cause the trans to overheat and fail.A TV cable that is fraying inside could keep the throttle from opening all the way, also it may bind and keep the throttle plate from closing entirely at idle position.
A 1990 F150 also had an E4OD trans available, shift points were controlled by the PCM and it has no cable for throttle valve pressure.You will have an OD switch on the dash if yours is euipt with an E4OD. A tps misadjustment could cause an early or late shift,a TPS with a bad spot will cause the trans to neutral or go into fail safe mode(2nd gear only IIRC)
The problem you have may be base adjustment of the throttle plate and the tps.
I dont recall the wire color, but the voltage should be something like .058-.062 volts at full closed throttle.Also the throttle plate should be at the full closed posisition, then the throttle stop screw should be set to keep the pressure from off the throttle plate, like just barely enough to hold the throttle plate from binding in the intake bore at full closed position.
A mis adjusted throttle plate or TPS could very well cause a rolling Idle, its not likely to cause an early shift as you described.If I had to guess, i would say you have an AOD with a TV cable issue, or TV problem.
The E4OD has shift adaptation capability in the PCM, if you drive it hard the shift parameters will modify themselves to accomodate your driving habits.


All times are GMT -6. The time now is 07:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.