TPS test parameters - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-25-2012, 10:24 PM
Registered User
 
Join Date: Feb 2012
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
TPS test parameters

I have a 1990 F150, 5.8L w/auto. I would like check the TPS voltages to see that they are as they should be but I do not know what the readings are supposed to be. And, also which colored wire to poke to test them. The idle rolls and truck shifts at 3900-4000, full trottle. Don't believe trottle is opening all the way, Thank You !

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-26-2012, 07:27 AM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,346
Wiki Edits: 0

Thanks: 222
Thanked 276 Times in 256 Posts
Chances are , if the TPS has a problem it would illuminate the check engine light.
If the check engine light is on , scan it for codes.Repair as instructed in the service manual.
The throttle not opening all the way would not be a TPS problem. You should be checking the throttle cable adjustment, or the cable itself to see if it has a problem.Maybe the thottle plate has an issue, disconnect the cables and see if it opens fully to check.
An AOD in that truck will have a throttle valve cable that needs to be properly adjusted to shift correctly, also if not correctly setup will cause the trans to overheat and fail.A TV cable that is fraying inside could keep the throttle from opening all the way, also it may bind and keep the throttle plate from closing entirely at idle position.
A 1990 F150 also had an E4OD trans available, shift points were controlled by the PCM and it has no cable for throttle valve pressure.You will have an OD switch on the dash if yours is euipt with an E4OD. A tps misadjustment could cause an early or late shift,a TPS with a bad spot will cause the trans to neutral or go into fail safe mode(2nd gear only IIRC)
The problem you have may be base adjustment of the throttle plate and the tps.
I dont recall the wire color, but the voltage should be something like .058-.062 volts at full closed throttle.Also the throttle plate should be at the full closed posisition, then the throttle stop screw should be set to keep the pressure from off the throttle plate, like just barely enough to hold the throttle plate from binding in the intake bore at full closed position.
A mis adjusted throttle plate or TPS could very well cause a rolling Idle, its not likely to cause an early shift as you described.If I had to guess, i would say you have an AOD with a TV cable issue, or TV problem.
The E4OD has shift adaptation capability in the PCM, if you drive it hard the shift parameters will modify themselves to accomodate your driving habits.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel system parameters- I wanna finish this tonight! Jeff The Ruler Hotrodding Basics 3 11-11-2009 03:39 AM
Temp. gauge sending unit parameters? Thinking Man Electrical 0 11-20-2007 07:12 PM
CBD test (car buying disease test) pigjamelectric Hotrodders' Lounge 8 02-11-2007 06:05 PM
Test Turbo1dr Introduce Yourself 2 12-03-2006 04:42 PM
The Hot Rod Test CrashFarmer2 Hotrodders' Lounge 83 01-01-2005 12:23 PM


All times are GMT -6. The time now is 08:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.