Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   tq issues with ultra bell (http://www.hotrodders.com/forum/tq-issues-ultra-bell-218769.html)

nskeeter99 04-29-2012 10:37 AM

tq issues with ultra bell
 
I snapped my bell housing on my 700. So i figured i would just up grad to the ultra bell. when i bolt it up to the motor, the tq is too tight. If i line it up with the raised bolt holes in the flywheel its super tight and you cant move it. If i line it up beside the holes with some effort you can move it. I don't have to back off the bolts much at all to get it to move. my tq is set in the pump. Am i stuck getting a new tq, are can i grind my mounts down a Little?. Maybe even cut the pump eats down a Little more.

S10xGN 04-30-2012 07:47 AM

I know you said it was, but it sure sounds like the converter is not fully engaged into the pump, and I hope you didn't force things too much as the pump can easily be ruined by doing so. First thing I'd do is go to a tranny shop and get a measurement from a stock 700, pump face to outer edge of the bell. Then compare that to your Ultra Bell and see if they're the same.

Russ


All times are GMT -6. The time now is 08:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.