Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   Trans slips out of overdrive under NO LOAD? (http://www.hotrodders.com/forum/trans-slips-out-overdrive-under-no-load-123030.html)

weirdbeard 08-26-2007 01:49 PM

Trans slips out of overdrive under NO LOAD?
 
I am just looking for an explanation on this. Its a 98 yukon with freshly rebuild auto trans. When I'm cruising over sixty it starts to slip out of OD up to 2000rpm. If I gas it a lil the darn thing drops back down to about 1400rpm where it should be. There is plenty of fluid in her. (Maybe to much?) It does not make any sense to me! You would think that it would slip worse under load...What am I missing here.
Anybody? :confused: :confused:

Chazmac 08-26-2007 07:59 PM

Under light load that trans is programmed to have minimal line pressure, among other control changes.
A test drive with scanner installed is required to to determine if it is 4th gear slip or TCC slip (more likely). Either way, have an experienced tech evaluate it. Soon.

Ohio-Dan 08-27-2007 02:52 PM

My guess, is that your throttle is at such a low position the the idle switch is activated causing the converter to un-lock. When you ease back into the throttle, the converter locks back up and drops your RPM's.....Dan

weirdbeard 08-27-2007 03:20 PM

That would be great if this was something I could fix. Its worth a check.
Thanks for the response. :thumbup:

weirdbeard 08-27-2007 03:24 PM

Quote:

Originally Posted by Chazmac
Under light load that trans is programmed to have minimal line pressure, among other control changes.
A test drive with scanner installed is required to to determine if it is 4th gear slip or TCC slip (more likely). Either way, have an experienced tech evaluate it. Soon.

What kind of scanner? I have a obd2 actron scanner. Could I use that. :confused: Would the repair for this involve removing the trans.? :pain:

weirdbeard 09-09-2007 12:09 PM

Quote:

Originally Posted by Ohio-Dan
My guess, is that your throttle is at such a low position the the idle switch is activated causing the converter to un-lock. When you ease back into the throttle, the converter locks back up and drops your RPM's.....Dan

I was hoping this might be it but after thinking about it and driving the truck I am afraid not. I can't get it to happen consistently. If it was a miss adjusted throttle sensor it should happen consistently under the same conditions. I am getting no codes for a trans problem. I know I need to take it to a pro but dangit :pain: The (pros) rebuilt this thing. :boxing: I don't like anybody to work on my cars but me. :rolleyes: Maybe I should toss in a manual trans. :sweat:

Crosley 09-09-2007 08:53 PM

I am not familiar with an actron scanner ... Does this scanner retrieve a "live data stream" that you can watch as the vehilce is operated?

IF the TPS has a bad spot in it the PCM will receive faulty information.

A view of the data stream will indicate IF the PCM is commanding OD while the trans drops out of gear. That would indicate an internal problem

The problem is IF the scanner shows all is OK with the data stream and the PCM commands.....

WHY is the trans dropping out of OD or is the Forward clutch pack the problem and it is releasing???

Or is the solenoid weak and not holding pressure for OD?

OR is the band apply pin not long enough and the servo can not apply it properly in OD? I've seen that many times.

Was the band a new unit during the rebuild?

Was band pin length checked during rebuild?

What does your trans rebuilder suggest as a process to move forward?


What is this "idle switch" that can be activated? I am not understanding that comment in a different response.


:cool:

matt167 09-09-2007 10:01 PM

Actron dosn't make any good scanners, there nothing more than code readers, I have 1, they do work in a pinch. need somthing like a snap on modis or a OTC genisis to get a datastream

weirdbeard 09-17-2007 04:22 PM

Yes my Actron scanner won't do live data. I see your point that there are many different things that could be the problem. I am not going back to the shop that rebuilt the trans. They will not be any help. I will take it to a guy my friends say is real honest.
From what I understand the idle switch is used to unlock the converter when you take your foot off the gas. I don't even know that this truck has that deal. That was someone else's suggestion. I would like an easy fix I could do myself but with newer cars that does not happen for me often.
Thanks for all your input. It just helps to talk about this stuff sometimes. :thumbup:

weirdbeard 09-23-2007 01:58 PM

Ok. I took it to a guy and he says its got to be a bad converter. I will find out for sure tomorrow. He is going to put a new one in.
I guess I could do that myself but it sucks to do transmission work in the dirt. I will just let him do it! :rolleyes:

weirdbeard 10-07-2007 11:40 AM

Just for some closer to this thread. I had the converter replaced and the problem came back that day! He said it was a bad part.. Its doing fine now. I think.. That was the first time I ever had to go to a mechanic. This truck is a POS! :smash:


All times are GMT -6. The time now is 04:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.