Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Transmission Issues with a Borg Warner Super T10
View Single Post
  #8 (permalink)  
Old 08-29-2010, 02:31 PM
Camaro83 Camaro83 is offline
Registered User
 
Join Date: Aug 2010
Location: Pennsylvania
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I'm going to have to look into adjusting the shift rods. I did notice the last time I was under the car the shift levers weren't perfectly even with the car in neutral. I've also had problems with the shifter (bolts un-threadded themselves, getting stuck in gear) and the transmission had the side case seal and bushings replaced (it was leaking fluid from side case which holds the 1-2 shift forks).

It seems that the shifter is binding sometimes as well, especially after driving it a distance then letting it sit for a few minutes. The shifter becomes very hard to move out of neutral or sometimes won't let you shift it into any gear when the car is off and still hot. Usually you have to push in the clutch to get it to release with the car off or start the car. It seems like the shifter is "off" as well because sometimes finding second gear is hard and 3rd gear is incredibily difficult at times as well.

I hope that adjusting the shift rods is a solution but I probably should be prepared for the worst. How much would it cost to replace the clutch "labor-wise" on this car? I know the oem clutch kit is around $150 but I don't have an idea on the labor. I've had clutches replaced in two FWD cars and one AWD car, which ranged from $700-$1000 easily including the clutch kit.
Thanks again for the help and for your replies.
Reply With Quote