Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   Transmission Leak (http://www.hotrodders.com/forum/transmission-leak-95647.html)

EazyDuzIt102 08-12-2006 05:45 PM

Transmission Leak
 
I just installed a new TH400 Tranny on my 65 Impala.I noticed that there is a slow drip of tranny fluid where the driveshaft goes into the tranny.Did I do something wrong?Any help is appreciated.Thanks,

Eazy

EazyDuzIt102 08-13-2006 12:26 AM

Anyone have any suggestions :confused: ?

Deuce 08-13-2006 12:53 AM

The seal may be damaged ...
I always put a little transmission fluid on the seal before installing the drive shaft.

ALSO ... did you use the same transmission rear extension ? They come is two different sizes ... at least.

http://www.flash.net/~partzman/23.TRANSC400TH.JPG

I put a large seal housing on a small housing drive shaft and had a leak ...

EazyDuzIt102 08-13-2006 11:05 AM

Well I had a Th400 in my car and the tranny went out.So I bought another th400.The tranny I put in is identical to the old one.So you think its the rear seal?

Jmark 08-13-2006 03:14 PM

It could be the rear seal. Was the new trans rebuilt or a used one? Was the rear extension housing bushing changed too? along with the seal?

red_rider52 08-13-2006 08:18 PM

If the seal is not new I would change it. Very cheap and easy to do, and go from there.


All times are GMT -6. The time now is 01:24 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.