tri-power help - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-19-2006, 07:44 PM
Registered User
 
Join Date: Jul 2006
Location: S.E. Wyoming
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
tri-power help

I've got a 331 Cad w/ 3 Stromberg 97's w/ 45 mains and and progressive linkage on an Edelbrock manifold. My problem is the back 2 cylinders (#7 & #8) are running HOT, especially #7. The basic functions of the carbs seem to be fine, float, pump etc. Any ideas from you 3 deuce experts?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-20-2006, 05:40 AM
woodz428's Avatar
Troll Hunter
 
Last photo:
Join Date: Sep 2002
Location: Philo,Il
Posts: 2,702
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I would suspect an air leak. Some flammable contact cleaner sprayed on the manifold/head joint and any other vacuum fittings in the area should pinpoint it.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power! -- No power? -- Power!!!! No Power???! Fragzem Engine 10 05-16-2005 01:30 PM
68 power steering burner Suspension - Brakes - Steering 5 04-06-2004 08:20 PM
Power Steering and Power Brakes blindboarder711 Suspension - Brakes - Steering 1 02-09-2004 02:54 PM
Car Audio Question Thuggishruggish3000 Interior 14 12-23-2003 08:48 AM
Tri power spam on e bay DragLinkscc Hotrodders' Lounge 0 05-10-2002 07:56 AM


All times are GMT -6. The time now is 02:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.