Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Trivia thread
Thread: Trivia thread
View Single Post
  #5919 (permalink)  
Old 02-05-2013, 02:47 PM
496CHEVY3100's Avatar
496CHEVY3100 496CHEVY3100 is offline
Appalachian American
 

Last journal entry: ,
Last photo:
Join Date: Jul 2012
Location: Appalachia GA
Posts: 793
Wiki Edits: 0

Thanks: 341
Thanked 260 Times in 229 Posts
Quote:
Originally Posted by MARTINSR View Post
It looks like it has no motor and was rolled off a car trailer.

Yep, I had a 64 Coupe. I bought it for $2500, this was about 1985. It needed everything and I started collecting it and then my now ex-wife left, I had to sell it and I see it fully restored once in a while around town. I had collected a bunch of real good stuff, a 327 out of an Impala at the wrecking yard made the same month as the Vette, an NOS shifter for the Muncie, a 365 horse intake, oh yeah it was looking good. Darn it, but I have to say without a doubt not a single doubt, loosing the Vette as a sacrifice to get rid of that woman, it was well worth it. Now, looking back I would have given away a whole friggin building full of restored Vettes to get rid of her, and that is no joke, not a bit, I am dead serious.

I rather have my Rambler and my forever wife beside me.

Brian
Actually im in a Shrine Parade in the picture it has a 327/350 hp L79 and a muncie m22 trans in the picture it had about 21000 mi now has 26900 miles all original exept 396 hood alternator ,and side exaust and rear filler panel i removed them in 1976 put on thru panel rear exaust still have panel and exaust. the front is not up the rear is lowered like i did all my 57 chevys/

Last edited by 496CHEVY3100; 02-05-2013 at 02:53 PM.
Reply With Quote