Trouble with 86 chevy 305 bogging down issues - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-18-2009, 03:05 PM
Registered User
 
Join Date: Jun 2009
Location: Fort Worth
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Trouble with 86 chevy 305 bogging down issues

I have an 86 chevy c10 with a 305 and a Rochester 4bbl Q-jet. I recently had the carb rebuilt cause of some other issues and they told me I would probably need a new carb in a year or so. The problem I am having now is at different times (accelerating or just cruising) the motor will just start losing power. It gets to the point where I cant get over 40 or 45 mph and if I punch the gas it just revs up as if the gears aren't catching or something. I'm not sure if it's a carb problem or if maybe it has to do with the transmission or if maybe it has something to do with timing. Any help or suggestions would be much appreciated!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-19-2009, 05:20 PM
fast68's Avatar
likes chevy trucks & boobies
 
Last photo:
Join Date: Oct 2005
Location: IL
Posts: 1,970
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
hmm well if the rpm is going up and you arent accelerating then yeah somethings wrong with the trans

if the engine runs fine and revs up good and seems to have good power just sitting parked then the carb is probably fine


rev it up under the hood by hand and slap[ the choke valve shut on it and then let go of the choke valve again before it dies and let the engine catch up again.

suck some dirt out of it

it usually improves things, such as idle and rev up

have to do this sometimes with them to clear them out, especially if they have been sitting parked often


hows the trans fluid look and smell ?

if its anything besides clean pure red and if it doesnt smell like nice new trans fluid then you at least need a trans pan drop and refill, if not a torque converter or new front pump or forward clutch pack if it really is slipping in drive trying to accelerate etc.

good luck

Last edited by fast68; 06-19-2009 at 05:30 PM.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-22-2009, 10:58 AM
Registered User
 
Join Date: Jun 2009
Location: Fort Worth
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Well, I got under there and found out that after they rebuilt the carb they didn't hook all of the vacuum hoses back up. I hooked them up and it does seem to be doing alot better, but does still occasionally bog down a little bit. Do you think it's safe to assume that this is because of dirt or debris getting in there somewhere? Thanks for your help!
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What is the best way to build up a chevy 305? sugarmonkey Engine 45 12-19-2009 05:26 AM
350 Chevy Issues engine trouble... Please help me! ineedspeed Engine 26 07-28-2008 04:23 AM
Chevy caprice 305 to 79 K10? jrm123180 Engine 1 11-22-2004 10:57 PM
86 - 305 what cam? Iroc'o Engine 2 10-09-2002 05:43 PM
Suggestions for my 305 Chevy Express engine? wrmason3 Engine 2 09-14-2002 05:51 AM


All times are GMT -6. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.