Truck Cold No Power off Line - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-16-2010, 08:52 PM
Registered User
 
Last photo:
Join Date: May 2009
Location: Alberta,Canada
Posts: 91
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Truck Cold No Power off Line

Hey guys, When my trucks still half cold and i take off with little throttle or half it sounds like its gunna stall unless i punch it then all power comes back.... Now when its up to operating temp it doesnt do that? Any ideas? its my 350TBI SBC chev motor in my S10..... ALso Ive been noticing my fuel mileage rapidly decrease and my engine running extremely rich. On highway driving after awhile my check engine light comes on. i had a code come up saying O2 sensor was also reading rich. I looked at the sensor and its pretty carboned up... Time for a new one?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-16-2010, 09:05 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,168
Wiki Edits: 0

Thanks: 199
Thanked 249 Times in 231 Posts
The oxygen sensor rich is just the indicator not the root cause.
Check the data stream values for the MAP sensor and the coolant sensor. Either one will cause a rich condition(or can ) if they are wacked out.
One other thing could be that the fuel pressure regulator in the throttle body is leaking into the intake. You can take out the 3 bolts that hold it down and lift it up about and inch. then cycle the key to run the pump ( get a helper) while looking under the throttle body. If the regulator is leaking you will see the fuel dripping.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-16-2010, 09:23 PM
Registered User
 
Last photo:
Join Date: May 2009
Location: Alberta,Canada
Posts: 91
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thnx for the reply. By data stream values do u mean i have to hook up a scanner to it again? I know i had my coolant sensor replaced last year along with my rad and thermostat so that should still be good. now map sensor im not sure about. I know I had a hose that was broken coming from the sensor into the intake which was making it run like crap until the computer sensed that then compensated for more fuel which set off a code. BUt i replaced that hose and cleared the code but it still running rich and it stinks like fuel especially out the exhaust. Im gunna take a look at that regulator tomorrow also and see if thats leaking. Is it part of the throttle body where the 2 injectors are or farther down?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-16-2010, 09:29 PM
Custom10's Avatar
my KARMA ran over my DOGMA
 

Last journal entry: SS
Last photo:
Join Date: May 2009
Location: Saskatchewan, Canada
Age: 49
Posts: 1,095
Wiki Edits: 0

Thanks: 14
Thanked 24 Times in 22 Posts
In most cases the system will default to rich mixture when the O2 sensor goes bad so what you have is normal, change the sensor and re-map bro.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 09-16-2010, 10:46 PM
Registered User
 
Last photo:
Join Date: May 2009
Location: Alberta,Canada
Posts: 91
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
haha ok good stuff. just quick question what do u mean by re maping ?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel return line - 79 chevy 1/2 ton Torque454 Engine 7 02-24-2010 11:32 PM
chevy 350 jimang22 Engine 4 07-14-2007 03:49 PM
Power Line Interference scorpio Electrical 1 09-16-2006 12:42 AM
Hotrodders Knowledge Cluster: Power Steering Conversions Jon Suspension - Brakes - Steering 0 09-03-2003 11:20 PM
Power truck tailgate? James Bond? PentastarTurbo Body - Exterior 7 05-12-2003 10:27 AM


All times are GMT -6. The time now is 09:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.