Truck shutting down - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 09-14-2010, 09:35 PM
Registered User
Join Date: Sep 2010
Location: Maryland
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Truck shutting down

I have a 95 ford f350 with a 7.3. they other day going home it shut down on me. After letting it sit for a min. it started back up and moved another 100 ft and shut down again. This went on for about a half hour before it just shut off as soon as it started. I got a new cam sensor and installed it but it wouldn't start. I put the old one back in and it started right up soIdrove it for about forty minutes and this started tohappen all over again. Is there such a thing as a bad sensor or do you think it may be the ipr valve shutting me down. The other thing is that I can start my truck without the key sometimes, do you think it might be the key switch and when I floor the truck it will bog down and shift hard every once in a while. Any suggestions would be great. Thanks 95Marine

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 09-14-2010, 10:22 PM
Registered User
Last photo:
Join Date: May 2009
Location: S/E Michigan
Posts: 650
Wiki Edits: 0

Thanks: 0
Thanked 9 Times in 9 Posts
You need to do some diagnosis. When it stops running, is there spark to the plugs? Is there fuel to the injectors? Can you hear the fuel pump engage? It could be any one of a thousand different possibilities.

Plugged fuel filter
bad ignition module
bad fuel pump
clogged cat converter
vapor lock
and one
and one
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-14-2010, 11:40 PM
Registered User
Last photo:
Join Date: Jan 2006
Location: Nanaimo, B.C., Canada
Posts: 671
Wiki Edits: 0

Thanks: 3
Thanked 18 Times in 18 Posts
First think I'd check is water in the fuel and fuel filter. Water's murder on diesels. It is a diesel right?
Reply With Quote Quick reply to this message

Recent Engine posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
94 chevy truck runnin' like poo! bluesmanjesse Engine 11 11-09-2006 03:54 PM
looking for a pic - the Navarro (?) families 68/69 chevy truck lowROLLERchevy Hotrodders' Lounge 0 10-03-2006 04:24 AM
My new(used) truck 1931 steve Hotrodders' Lounge 5 09-02-2006 12:54 PM
help identify truck blackbeard Suspension - Brakes - Steering 2 01-25-2005 07:28 AM
Ebay Truck Headache CrashFarmer2 Hotrodders' Lounge 8 09-06-2003 08:30 PM

All times are GMT -6. The time now is 09:57 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.