truck troubles - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-28-2010, 08:06 PM
Registered User
 
Join Date: Nov 2009
Location: wyoming
Posts: 70
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
truck troubles

hey guys srry to keep bugging you all the time lol but i need help with the engine on my 80 gmc half ton 4wd with a 350 it just isnt as snappy as i think it should be and ive been told that my kick down cable isnt hooked up but idk and well heres the problem when u step on it while cruising it spits once then takes off and idk whats going on please help

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-28-2010, 08:44 PM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,658
Wiki Edits: 0

Thanks: 15
Thanked 60 Times in 57 Posts
Did you remove the adapter plate on it? Did you set the spark timing correctly and be sure it was advancing? When a engine isn`t in tune it`s not very snappy at all.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-28-2010, 08:49 PM
Registered User
 
Join Date: Nov 2009
Location: wyoming
Posts: 70
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
truck troubles

yes i did i gave it a full tune up of everything plugs wires oil air filter oil filter the works and it still just lags a little bit or unless u stab the go pedal to the floor it spits and then accelerates i was told it might be the carb is dirty and to dump a bottle of sea foam down it and run it through
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-28-2010, 09:02 PM
GMC boogie's Avatar
Member
 
Last photo:
Join Date: Nov 2004
Location: Louisiana
Age: 49
Posts: 632
Wiki Edits: 0

Thanks: 1
Thanked 22 Times in 22 Posts
Check the vacuum advance on the distributor to make sure its working.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-28-2010, 09:03 PM
Registered User
 
Join Date: Nov 2009
Location: wyoming
Posts: 70
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
truck troubles

k how would i tell if its working or not
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-28-2010, 09:17 PM
GMC boogie's Avatar
Member
 
Last photo:
Join Date: Nov 2004
Location: Louisiana
Age: 49
Posts: 632
Wiki Edits: 0

Thanks: 1
Thanked 22 Times in 22 Posts
One way is to connect a timing light and remove/apply vacuum to the advance can while watching the timing mark with light,it should move at least 10.

It is not uncommon for these to go bad.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-28-2010, 09:57 PM
Registered User
 
Join Date: Nov 2009
Location: wyoming
Posts: 70
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
truck troubles

ok now where would i find the kick down cable to see if its hooked up that way i can down shift if i punch it to hop on the interstate
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 07-29-2010, 12:06 AM
sqzbox's Avatar
My pipes are my music
 
Last photo:
Join Date: Sep 2009
Location: indiana
Age: 64
Posts: 2,938
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
If your running a carburator, it sounds like your accelerator pump needs work.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
94 chevy truck runnin' like poo! bluesmanjesse Engine 11 11-09-2006 03:54 PM
looking for a pic - the Navarro (?) families 68/69 chevy truck lowROLLERchevy Hotrodders' Lounge 0 10-03-2006 04:24 AM
My new(used) truck 1931 steve Hotrodders' Lounge 5 09-02-2006 12:54 PM
help identify truck blackbeard Suspension - Brakes - Steering 2 01-25-2005 07:28 AM
Ebay Truck Headache CrashFarmer2 Hotrodders' Lounge 8 09-06-2003 08:30 PM


All times are GMT -6. The time now is 02:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.