Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Tube chassis front strut pre-load
View Single Post
  #2 (permalink)  
Old 08-30-2011, 10:13 AM
35terraplane's Avatar
35terraplane 35terraplane is offline
Registered User
 
Last photo:
Join Date: Sep 2010
Location: MN, ON THE DARK SIDE OF THE MOON
Age: 70
Posts: 1,310
Wiki Edits: 0

Thanks: 2
Thanked 50 Times in 44 Posts
Pre-load

Quote:
Originally Posted by 9K-sbc
I just picked up a tube chassis car (roller) with a strut front suspension, the passenger side strut is set lower (and softer) than the drivers side and has about 1" of travel when I stand on the frame. This seems backwards to me, shouldn't it be the other way around since the drivers side pulls up? I can stand on the drivers side frame and the strut doesn't budge, it didn't even drop when I put the engine in. (passenger side dropped a little with engine in). this is my first strut style suspension and the guy I got the car from said it launched OK and that he had never messed with it and it was running 8.50 1/4 mile as is. The motor I'm putting in is pretty hot and even testing at part throttle could put me in the wall if things are way out of whack. Anyone have any advise? (not sure if I trust this guy)
You can get answers here, but you will still need to adjust them when you are getting it dialed in what I would do is start reading up on strut style front ends.

I think it would be the back end that would put you in the wall, before the front JMO. Good luck, have fun racing.

Bob
Reply With Quote