Tune Up. Check Engine Light - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-21-2003, 06:29 AM
Member
 
Join Date: Dec 2002
Location: Buffalo, NY
Posts: 32
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post Tune Up. Check Engine Light

I posted this in the general section but thought it would be best to put it here. Webmaster: If you would like you can delete the other post. Thank you.


My check engine light came on the other day. Had it checked out and they said that the light comes on around 60-70 for my 97 Dodge Avenger when it needs a tune up. So here goes. I took a look at the plugs on her and three of the six are burried under what looks like some sort of intake. I am heading to the shop today to pick up the repair manual to see what the process is but thought someone on the BBS might have some ideas on the plugs under the intake. Next question. What should I be doing for the tune up that may not be in the maintenance section of the manual? Maybe some tips if there are any out there. And lastly. The check engine light. If I do the tune up how can I insure that the light will turn off? How does it know it needs a tune up? Is there something I need to reset? Thanks in advance guys/gals. Everyone on this board has always been a great help.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-21-2003, 09:49 AM
MonteCrl's Avatar
Member
 
Last photo:
Join Date: Aug 2002
Location: Chicago, IL
Age: 33
Posts: 31
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Yup new Chrysler engines suck if you have to work on them. You do have to take off the upper manifold to get to the back 3 plugs(wouldnt have to if it wasnt a hemi head) The Engine light is most likely on for another reason but try a tune up if it needs one anyway and then if the lights still on get it scanned. I do know that the light can go on if the ECU detects a missfire so bad plugs and such could cause it.

[ April 21, 2003: Message edited by: MonteCrl ]</p>
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 10:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.