Turn Signal lights not working only when engine is running. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-03-2012, 08:14 PM
Registered User
 
Join Date: Jun 2012
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Turn Signal lights not working only when engine is running.

93 Mercury Topaz. The turn signal lights are not working when the engine is running. They work fine when I leave the keys in the ignition without the engine running. What could be wrong?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-04-2012, 06:11 AM
67Mustang Al.'s Avatar
Registered User
 
Last photo:
Join Date: Jan 2009
Location: Tasmania, Australia.
Posts: 433
Wiki Edits: 0

Thanks: 2
Thanked 6 Times in 6 Posts
Indicators

If you find the flasher unit and the +12 v hot wire feeding into it using a $6 light pen with a pointed end+ ( and a clip for the -ve end to chassis) turn the key to accessories and then start the engine with the 12v light probe still connected to the hot wire. If the light goes out you will need to follow that wire back to its power source by probing the wire with the sharp point of the light pen. Power should come from the fuse panel to the flasher unit with ignition on then travel to the indicator stalk to be switched left or right by the stalk. If the fuse blows you have a short , if it does not then you have a power drain with engine running. Check headlights for dim light. Alternator ok?? 14v approx.
Hope this gets you started.
Al.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Driving Lights to Turn Signal Conversion 440man Electrical 21 01-17-2012 06:43 AM
Taillights/turn signals/running lights Not Working PancakesandSausage Electrical 30 01-27-2011 04:02 AM
Rear Turn Signal Not Working With Lights ON Craig legacy Electrical 1 09-02-2010 02:38 PM
Parking lights from Turn signal lights 32chevy vett Electrical 7 03-30-2007 06:46 AM
How to convert to flashing hedlights instead of turn signal lights!! willys36@aol.com Electrical 5 08-11-2004 07:16 PM


All times are GMT -6. The time now is 03:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.