Turn Signals Quit Working - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-30-2010, 03:28 PM
10mikeymike's Avatar
Registered User
 
Last photo:
Join Date: Jul 2008
Location: Northville, MI
Age: 68
Posts: 51
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Turn Signals Quit Working

I have a 37 Ford with a Kwik Wire 14 circuit wiring harness and a Flaming River tilt column. The other evening my turn signals quit working. I swapped out the old flasher with a new one and they worked for a minute and then stopped. I pulled out the new flasher and sprayed a little electric parts cleaner in the circuit board and replaced it. They worked again for a minute and then quit. I did this a couple of times and then realized that I could make them stop working by stepping on the brake. I did a search and found an old post from a guy with a Vette who was having an identical problem. In his case, there was a relay that was at fault. To my knowledge, there is no separate relay in my setup for the turn signals, only for the emergency flashers. All the bulbs are good and working properly. So are the emergency flashers. I've tried 2 new flashers with the same results.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-30-2010, 06:23 PM
vicrod's Avatar
life is a ride
 

Last journal entry: 2014
Last photo:
Join Date: Nov 2005
Location: Telford, PA
Age: 71
Posts: 1,307
Wiki Edits: 0

Thanks: 0
Thanked 56 Times in 52 Posts
Part the turn signal switch is the hazard flasher switch.
When the hazard flasher switch is NOT in use the contacts are closed thus enabling the turn signals operate.
Referring to the attached diagram see the closed "hazard" contacts that complete the circuit to the turn signals. Labeled on the diagram as "normal".
If these contacts are not making a good connection your turn signals won't work.
I know Flaming River is a good operation BUT things break>>>

vicrod
Attached Files
File Type: pdf gm turnsignals.pdf (55.2 KB, 49 views)
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-30-2010, 06:25 PM
Registered User
 
Last photo:
Join Date: Nov 2005
Location: Delta, Pensylvania
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
If you have a 3 pole flasher it wires in hot through the brake lite switch. There is a possibility that you break switch has a problem. If not check all bulb sockets turn signals can cause weird things to happen.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-30-2010, 06:59 PM
T-bucket23's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 57
Posts: 5,099
Wiki Edits: 26

Thanks: 7
Thanked 103 Times in 88 Posts
If it is plugging into a board, there may be a crack or a cold solder joint. I would try turning the blinger on and push on the flasher and area where it plugs in to see if you can make it come and go. If you can you can look at the area where it plugs in for breaks or bad solder joints
__________________
Artificial Intelligence is no match for Natural Stupidity



Chet
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-31-2010, 08:23 PM
10mikeymike's Avatar
Registered User
 
Last photo:
Join Date: Jul 2008
Location: Northville, MI
Age: 68
Posts: 51
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks to all for your responses. I found the problem. It waws a bad connection where the wire enters the back of the circuit board.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signals on Headlight Buckets ratfink35 Body - Exterior 1 04-17-2008 08:16 AM
'67 Tempest turn signals and tach q's 'Vid Electrical 0 10-09-2007 07:09 PM
Wiring For Turn Signals Seon Electrical 5 12-26-2005 12:04 AM
No turn signals. hogggster Electrical 1 04-15-2003 07:01 PM
turn signals impala dreaming Electrical 5 02-24-2003 06:29 PM


All times are GMT -6. The time now is 12:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.