Uh what a mess!!!! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-10-2004, 08:48 PM
Jag Daddy's Avatar
British Style with USA Muscle
 
Last photo:
Join Date: Mar 2003
Location: Valencia, California
Age: 57
Posts: 1,078
Wiki Edits: 0

Thanks: 7
Thanked 0 Times in 0 Posts
Uh what a mess!!!!

Well I was working on the Jag the other night and I needed to drop the lower dash panel. ARGH! what a mess, wires were draped over vents and poorly connected. Also wires that went nowhere with power on them and bare wires showing too. I spent most of today cleaning up the dangerous stuff and rewiring the electric antenna at the back of the car. It's all in spiral wrap and protected now. I'm thinking the best thing to do Is take ALL the PO stuff out and start from scratch.

I wanted to install an MP3 player anyway, I kind of like the 11 hours per disc idea. I was thinking of one they have at Wal Mart for $90.00. My other option would be XM, anyone tried it yet?

Regards
Mark

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-11-2004, 01:25 PM
horvath's Avatar
Acoustic Rock ... for real.
 

Last journal entry: About Fusible Links
Last photo:
Join Date: Feb 2003
Location: Central New Jersey
Age: 63
Posts: 1,982
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Haven't tried it yet, Mark, but from what I've heard it sounds like a very cool thang.

Nearly the first thing I did when I got my truck was to rewire the whole thing, and it was a most WISE decision! The things POs did over the years was scary -- to say the least! It took me 10 days, but I really had fun doing it and I sure feel safe and secure every time I go somewhere, too!

Alan
54 Chevy Pickup
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 03:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.