Used beast sunshell sold as New? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-03-2012, 11:12 AM
Registered User
 
Last photo:
Join Date: Jul 2012
Location: Colorado Springs
Age: 27
Posts: 73
Wiki Edits: 0

Thanks: 51
Thanked 1 Time in 1 Post
Used beast sunshell sold as New?

Hello,

I received this beast sunshell as part of a rebuild kit for my 4l60e.(98 chevy k1500 5.7 350) When I was unpacking the box I inspected this sunshell and it looks used or abused to me. I can feel these shiny spots with my fingers very easily.

Can anyone tell me if this is normal from manufacturing or if they are trying to pull a fast one?

When I pay for something that is new I expect it to be smooth and straight.

Thanks.
Attached Thumbnails
Click image for larger version

Name:	DSCN0263.JPG
Views:	85
Size:	34.2 KB
ID:	67178  

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-03-2012, 12:00 PM
Registered User
 
Last photo:
Join Date: Jul 2004
Location: At Speed
Age: 51
Posts: 1,342
Wiki Edits: 0

Thanks: 2
Thanked 27 Times in 27 Posts
Looks like tool marks from being die formed, but I'm no trans guy.
Automatics work by magic as far as I know.
Reply With Quote Quick reply to this message
The Following User Says Thank You to lmsport For This Useful Post:
abbazabba (08-03-2012)
  #3 (permalink)  
Old 08-03-2012, 09:13 PM
joshp83's Avatar
owner of Prices Garage
 
Last photo:
Join Date: Jun 2011
Location: west virginia
Age: 31
Posts: 317
Wiki Edits: 0

Thanks: 0
Thanked 23 Times in 23 Posts
every one i bought have simlar marks look at the splines if its used u can see wear marks on them
Reply With Quote Quick reply to this message
The Following User Says Thank You to joshp83 For This Useful Post:
abbazabba (08-04-2012)
  #4 (permalink)  
Old 08-04-2012, 11:52 PM
Registered User
 
Last wiki edit: Transmission identification
Join Date: Mar 2008
Location: Terra
Posts: 686
Wiki Edits: 85

Thanks: 0
Thanked 23 Times in 21 Posts
There is NO way those marks could have happened after installation in a transmission. So, they must be normal.
Reply With Quote Quick reply to this message
The Following User Says Thank You to mmerlinn For This Useful Post:
abbazabba (08-05-2012)
  #5 (permalink)  
Old 08-05-2012, 10:05 AM
Registered User
 
Last photo:
Join Date: Jul 2012
Location: Colorado Springs
Age: 27
Posts: 73
Wiki Edits: 0

Thanks: 51
Thanked 1 Time in 1 Post
Thanks for all of your input.
Reply With Quote Quick reply to this message

Tags
4l60e, beast, chevy, sunshell

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sold badknuckles Hotrodders' Lounge 4 05-12-2011 10:50 PM
high squeal after installing sunshell, shaft, and ring gear assembly old yukon Transmission - Rearend 6 04-27-2011 11:10 PM
i got the upgrade 4L60e sunshell, but no thrust washer.... old yukon Transmission - Rearend 5 04-11-2011 07:22 PM
Lower reverse clutch race and new sunshell, is a mod needed old yukon Transmission - Rearend 8 04-11-2011 07:21 PM
Sold Sold 73-454 Vette Sold Edge-Net Engine 3 09-28-2003 01:34 PM


All times are GMT -6. The time now is 08:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.