Used compressor checks - advice? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Garage - Tools
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-17-2006, 12:12 PM
Registered User
 
Join Date: Jul 2006
Location: Montana
Age: 53
Posts: 23
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Used compressor checks - advice?

I've been reading posts on compressors here for months now, finally got one last week. Thanks to everybody, especially oldred, for all the advice. I bought a used 6 year old QT-5 5 hp, 60 gal. 2 stage Quincy for $600. Seemed like a snooze you lose deal, so I grabbed it quick. Probably OK, but I'm realizing it wasn't maintained at all. I'm wondering about things I should check before cranking it up (haven't seen it run yet), any advice is appreciated.
The oil looks like it was never changed, factory sealant on the drain plug still had flawless paint. Rough guess by what he said, it probably has at 2000 hours (+/- ???)on it. Any damage from that you think? A few tiny metal flakes in the oil when I drained it, didn't seem bad though.
The pressure gauge is sprung, reads 50 psi with tank empty. I got a new one (Acme), but am a little concerned at what would cause that?? Glancing at the pressure shutoff adjustment and comparing it to a new one here, looks like the nut is at the same depth. I figured, assuming the new gauge is accurate, I'll see as it pumps up - should cut out at 175 psi, right? And if he messed with it (have read your warnings on that oldred), release valves should go. Release valves seem to move OK.
He said he drained the tank every day, he used it for paintball tanks and needed dry air. Banged on the bottom, from some from advice here, sounded solid.
Still need to wire it up, motor is a 21 amp Baldor, so 30 amp 220 with 10 ga. wire (about 30 ft.) should be good, right?
Anything else I should check? Will get a new air filter too. The guy seemed real nice, said he'd take it back if there was any problem. He replaced with a super high CFM tankless thing that suits paintball better.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-17-2006, 02:21 PM
Member
 
Last photo:
Join Date: Jan 2003
Location: tennessee
Posts: 5,913
Wiki Edits: 0

Thanks: 0
Thanked 7 Times in 7 Posts
First of all it takes a LOT of abuse to hurt a Quincy! I am certainly not saying it is ok to never change oil but I have seen a bunch of compressors of different makes neglected in this manner over the years and it does not seem to damage them as much as one might think so if the pump is sound and builds pressure ok after changing the oil don't worry about it. That gauge was probably struck and bent at one time which is common damage for a gauge usually resulting in the problem you described, once the case is bent replacement seems to be about the only solution as they never seem to work right even after straightening the damage. It should cut off around 175 PSI and if it goes over that then the regulator has been tampered with and it should be reset before operating the compressor, it may be 165 or even 145 depending on the particular unit and this would be ok. After it has built up pressure and shut off listen for air leaks around the lines and the head/valves on the pump but DO NOT feel for leaks on the lines with your bare hands as a pin hole leak could cause serious injury, this is not very likely but it could happen. It sounds as if you got a real deal there and if in good shape it is going to last you a long time but if service and/or parts are required you will find that anything needed to repair this outfit will be available.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-19-2006, 05:24 PM
Registered User
 
Join Date: Jul 2006
Location: Montana
Age: 53
Posts: 23
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Thanks, oldred, I figured from your experiences with Quincys it would hold up pretty well. Got it started up, shuts off right at about 175 psi. I couldn't hear any leaks, it did lose about 10 psi overnight. I brushed soapy water on most of the connections, couldn't find any leaks. Guess you can't expect perfection for that price! Maybe I'll find a leak later.

If anybody is looking for some wiring help, here's an electrical forum that has some electricians who seem very knowledgable. This thread (on wiring a garage for auto work) is an example of the detail Wgoodrich, an electrical inspector (his credentials bottom of page here.) who administrates the site, goes to in some of the older posts. Course it shows why it's easier to just hire an electrician sometimes too!

Thanks again to all the members here for your help so far, I've read a lot of your posts. It's been 18 years since I did a lot of rebuilding cars, this helps me back up to speed.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 12-19-2006, 07:04 PM
boatbob2
 
Join Date: Dec 2005
Location: north florida
Age: 76
Posts: 1,375
Wiki Edits: 0

Thanks: 6
Thanked 26 Times in 23 Posts
air compressor

hi,on my compressor,i took a 90 degree bend straight down from the air outlet (top of tank about 2 ft,then a water hose valve,then another 90 back up to where i started ,but about 4 inches to the side,in other words,i made a big U with the water hose valve at the bottom. at the top of the U,i put my regular air line fitting. now,when im using the comp,about every 30 minutes i open the water hose valve,and drain the water,.you would be surprised how much water is caught and drained ...also,i change my comp oil every 90 days,i put the date on the tank with a magic marker. im boatbob2
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 12-20-2006, 11:26 AM
snod83's Avatar
Member
 
Last photo:
Join Date: Mar 2004
Location: Ohio
Age: 31
Posts: 143
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
I would be a little worried about what the gentlemen told you, as if he was filling paintball tanks with it, it would have to have held 3000 psi! There are no real low pressure paintball guns around.

Ryan
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 12-20-2006, 01:28 PM
Registered User
 
Join Date: Jul 2006
Location: Montana
Age: 53
Posts: 23
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Yea, Ryan, that was part of why I was wondering about the sprung gauge. I forgot to mention he said he had some device after the compressor that boosted the psi to what paint ball needs. The new one he got to replace this compressor was something that did super high psi in one shot.

I assume there's no way any super boosted high pressure got back into the Quincy though, since the tank is only rated to 200 psi?!
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 12-20-2006, 02:42 PM
Member
 
Last photo:
Join Date: Jan 2003
Location: tennessee
Posts: 5,913
Wiki Edits: 0

Thanks: 0
Thanked 7 Times in 7 Posts
It is possible that the reason that gauge is sprung is due to overpressure(not 3000 PSI though) but if that is so and everything seems normal now then about all it did was to pressure test the tank, it probably did not damage anything. I would guess that it would take well over 300 PSI to rupture that tank if it is not damaged due to corrosion or impact but I would NEVER allow that much pressure intentionally and I hate to think how much damage a tank that size with that much pressure would cause if it were to burst. I have seen compressors run well in excess of 200 PSI in some mine shops and on a couple of service trucks but I refused to service these and warned the owners of the danger but the fact is they have run them like that for years, still does not mean it is safe. If a compressor is set up for that much pressure from the factory and rated to operate that high it would be ok but to tamper with a regulator and relief valve is extremely dangerous. One of the compressors I mentioned did rupture back around 1989 at a mine in KY seriously injuring two workers and destroying the cab on a Mack truck.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 12-20-2006, 08:18 PM
Registered User
 
Join Date: Jul 2006
Location: Montana
Age: 53
Posts: 23
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
I started worrying about the tank maybe being overpressurized, then realized unless the pressure release valves failed somehow, that couldn't happen. And that wasn't a typo on the 3000 psi pressure, I was reading about how some paintball tanks use 4500 psi and more! I assume what this guy had was basically a 3rd stage compressor to take the 175 psi and boost it to 3000 psi or more. But even if he hooked something up backwards and sent that pressure to the Quincy tank, should just blow the safety release valves, right? He was filling smaller tanks with the higher pressure, maybe 20 gallons.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 12-21-2006, 07:04 AM
Member
 
Last photo:
Join Date: Jan 2003
Location: tennessee
Posts: 5,913
Wiki Edits: 0

Thanks: 0
Thanked 7 Times in 7 Posts
I am sure that the tank would rupture long before it reached 3000 PSI so I am sure it never had that much pressure. As far as the pressure relief valves I have seen those things replaced with plugs when someone was screwing around with the pressure regulator. Like I said earlier if everything seems normal now I would'nt worry about past overpressure, unless maybe the tank is bulged out in the middle?
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 12-21-2006, 01:34 PM
Registered User
 
Join Date: Jul 2006
Location: Montana
Age: 53
Posts: 23
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Wow, pressure relief valves plugged, that's scary. Mine has both relief valves, one on top of the tank and one at the pressure regulator switch. I checked the tank with a straightedge, don't see any bulging at all. So sounds like all is good, since the both relief valves move and open. I suppose it's possible they open at too high a pressure, but for both to be faulty like that seems unlikely.
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 12-21-2006, 02:52 PM
Member
 
Last photo:
Join Date: Jan 2003
Location: tennessee
Posts: 5,913
Wiki Edits: 0

Thanks: 0
Thanked 7 Times in 7 Posts
That tank would have to bulged out noticeably to be something to worry about. From what you have described I would think that compressor is in fine shape and should last a long time and IMO you got a heck of a deal on it.
Reply With Quote Quick reply to this message

Recent Garage - Tools posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Camaro rear end advice gavinpierce Transmission - Rearend 2 08-09-2006 03:17 PM
replacement pickup truck - your advice please jojo99 Hotrodding Basics 7 05-03-2006 11:52 PM
replacement pickup truck - your advice please jojo99 Engine 3 04-28-2006 05:48 PM
replacement pickup truck - your advice please jojo99 General Rodding Tech 6 04-28-2006 02:18 PM
350 advice 73AggieVette Engine 4 02-09-2006 05:32 PM


All times are GMT -6. The time now is 04:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.