Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Vacuum Vs. mechanical advance (http://www.hotrodders.com/forum/vacuum-vs-mechanical-advance-51012.html)

stinky jinx 11-01-2004 09:52 PM

Vacuum Vs. mechanical advance
 
As some of you know I have been chasing an off idle stumble. This happens from a dead stop (medium to hard acceleration) and when cruising as I hit the throttle. I have a Mallory Unilite Comp 9000 distributor ( mechanical / breaker- less) in a 350 Chevy motor (8.5/1 compression,a mild performance cam, headers,air gap manifold, 670 Holley). It has been suggested that a distributor with vacuum advance (HEI) would eliminate this hesitation because the advance would come in much smoother and sooner. And that the Unilite that I am using is really for a much healthier engine and one with a higher RPM range. What do you boys think?

benwantland 11-01-2004 10:54 PM

What does your advance curve look like? I don't think you need vacuum advance if your distributor is setup right... I have a stock-short-blocked Ford 300-6 (about 8:1 comp) with no vacuum advance, and it runs great, except for the flat cam....

Anyway, what are your initial and total advance numbers, and at what rpm? Do you have a timing light? If you don't, that's the first step.

stinky jinx 11-01-2004 11:31 PM

benwantland,

my timing at this moment in time is 16 and 40...... but the the curve doesn't begin until about 1800-2000 .....,, but this hesitation discussion has been gone over ...and over ...and over ...at this point I am just interested in input as to wither or not a vacuum advance will work better on my fairly stock engine........

Centerline 11-02-2004 07:22 AM

Chevys for some reason almost always react better on the street with a vacuum advance distributor. They also run cooler. With the proper advance curve setup and a good vacuum advance distributor you should be fine.

Centerline

DoubleVision 11-02-2004 07:46 AM

Ditto with Centerline. I ran my close to stock sbc on a ported vacuum source for a long time, but I never could figure out why the car was such a slug off idle, it had very little low end power, my combo consists of a crane 210 216 duration cam, flat top pistons, 041 heads, weaind stealth intake, demon carb, headers, HEI with flame thrower coil and module, 3.23 gears and posi.
The car wouldn`t get out of it`s own way off idle, it was the most pathetic unthrottle responsive slug I ever owned, I didn`t understand why with the pieces I chose it had no power, I had read many posts that said vacuum advance was needed at idle and should be on a manifold source, I didn`t believe it, since I didn`t see the need for it at idle, BOBCRMAN suggested I move it to a manifold source, I did and the difference was incredible, off idle it moves and moves fast, throttle response got a 100% better, mileage improved greatly, It finally ran like it should have ran. The need for vacuum advance at idle and off idle is because these mixtures are lean, and lean mixtures burn slower than do rich mixtures, so the added advance is needed. Vacuum advance is especially effective in a low compression application.

killerformula 11-02-2004 08:24 AM

I guess I just don't believe in the "try this, try that" type of analysis. If it were mine, here's what I would do:

First pull your plugs and read them. What color are they?

Second, find out where your timing is!!! Don't do ANYTHING until you find out where you're at right now.

Mild cam? How mild? What duration? A little too much duration and its going to be a bit of a dog off idle with 8.5:1

Gears?

Your problem may be simply fixed by a stall converter!

How is this hesitation coming in? Do you notice it even with very light throttle, or when you give it a stab to half throttle it falls on its face for a minute?

K

stinky jinx 11-02-2004 10:22 AM

Killer,
your quotes are below and I answered them after each question with the answer coming after the periods.............jerry

Quote:

Originally posted by killerformula
I guess I just don't believe in the "try this, try that" type of analysis. If it were mine, here's what I would do:

First pull your plugs and read them. What color are they?

Second, find out where your timing is!!! Don't do ANYTHING until you find out where you're at right now...............my timing is 16 and 40

Mild cam? How mild? What duration? A little too much duration and its going to be a bit of a dog off idle with 8.5:1....................I am not sure of the cam, it was in the engine when I got it.my vacuum is high at 18 in gear, so it is probably mild.

Gears?..................343s

Your problem may be simply fixed by a stall converter!..................2200

How is this hesitation coming in? Do you notice it even with very light throttle, or when you give it a stab to half throttle it falls on its face for a minute?...................medium to hard stab.

K


killerformula 11-02-2004 11:09 AM

thats a lot of initial timing, but you might be ok with it. Are you getting run-on after you turn the car off, or is your starter turning slowly or getting kickback? Sounds like a carburetor problem. Pull your plugs and read them!

I'm assuming two things can be causing your problem:

In the carb your pump shot or transition circuit could be too agressive. A lean condition would be heard as a "pop" coming from the carb. Rich is usually a bog. A less agressive squirter or pump cam may be necessary.

You can also try to bring in your advance more quickly. Maybe run a couple of degrees less initial, but make the mechanical come in more quickly by changin the springs to a lighter set.

When does your mechanical start coming in, and when is it done?
K


All times are GMT -6. The time now is 11:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.