valve train problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-10-2010, 04:10 PM
Registered User
 
Join Date: Sep 2010
Location: texas
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
valve train problems

ok guys,here's one for ya.I have a 355 sbc roller with Comp solid roller cam(660/630 lift),jessel roller lifters,comp pushrods,stainless roller rockers on pro comp aluminum heads(2.05/1.60 valves with dual springs for roller setup).My problem is the rockers keep coming off the studs.no bent pushrods or anything broken,seems to happen on the intake only.Anybody got any answers why?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-10-2010, 04:17 PM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,673
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
You mean like the nut is just coming off or something? What kind of rockers? Do you have the right length pushrod?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-10-2010, 04:24 PM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 12,565
Wiki Edits: 326

Thanks: 698
Thanked 877 Times in 745 Posts
Quote:
Originally Posted by vetteracer77
the rockers keep coming off the studs.
Makes no sense at all. Please detail the problem for those of us who aren't clairvoyant.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-10-2010, 04:26 PM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,673
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Quote:
Originally Posted by techinspector1
Makes no sense at all. Please detail the problem for those of us who aren't clairvoyant.
Hahaha, i was trying to say the same thing in a nicer way. lol. I like the straight forward answer.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 11-10-2010, 06:12 PM
Registered User
 
Join Date: Sep 2010
Location: texas
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
valve train problems

the nut works its way off the stud and believe me ,Its tight!The rockers are procomp stainless 1.5 rollers.The pushrods were checked by a guy I know that works for Arrow Machine and we both came up with the same lenghts.Never hurts to double check something like that.So what other information do u need?
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 11-10-2010, 06:54 PM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 12,565
Wiki Edits: 326

Thanks: 698
Thanked 877 Times in 745 Posts
Quote:
Originally Posted by vetteracer77
the nut works its way off the stud and believe me ,Its tight!
You're still withholding information.
Did the studs come in the heads when you bought them or did you install the studs yourself? If they were in the heads, have you removed them and reinstalled to verify equal torque? If you did it, whose studs did you use and what did you torque them to? What size are they? Who made them? What material are they made from? Have you laid a straightedge on the valve tips to see if any of the valves are sunk further into the head than other valves? Have you laid a straightedge on the side of the valves at the top to see if any of them are bent? Have you laid a straightedge onto the top of the studs to see if any are shorter or longer than the others? Have you laid a straightedge onto the side of the studs at the top to see if any of them are bent? What kind of rocker nuts are you using? Who made them? What material are they made from? What is the O.D.? Does the O.D. of the nuts mate up with the recess in the rockers? Any interference? Are any of the valve stem tips laid over and out of square? Can you see on the bottomside of the lock screw that you are engaging the full circumference of the lock screw onto the top of the stud? Can you see witness marks on the top of the studs that are fully 360 degrees around the end of the stud? Have you inspected for valve to piston clearance, retainer to seal clearance and valve spring coil bind? Are you using a gear drive?
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 11-10-2010, 07:47 PM
Registered User
 
Join Date: Sep 2010
Location: east of the rockies
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I have had a few customers bring in pro comp heads, rockers etc. as Tech inspecter said, I have found that the rockers do not fit the studs very well. the top of the studs need attention for poly locks to work properly. Also with the lift you are using, i asume you are using .100-.200 longer valves?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Valve Lash adjustment hiball Engine 36 05-11-2009 10:12 AM
MAJOR Valve train Problems nova69 Engine 3 04-17-2009 10:12 AM
700R4 Why are the TCI manual valve body instructions so lousy? Bayley Transmission - Rearend 24 02-16-2009 12:49 PM
Adjusting olds rockers .... HELP A/G WILLYS Engine 9 08-21-2008 12:22 PM
pontiac valve problems 69goat4fun Engine 3 07-22-2004 02:34 PM


All times are GMT -6. The time now is 08:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.