Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Very Involved Problem 400sbc
View Single Post
  #1 (permalink)  
Old 12-07-2012, 07:05 PM
89k1500 89k1500 is offline
Registered User
 
Join Date: Dec 2012
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Very Involved Problem 400sbc

First I'd like to apoligize for making my first post a "Help Me" post. Kinda rude but I to just get to the point.

I have a 89 chevy 4x4 with a drivibability issue, which is: The truck (5 speed manual) will pull good in first and second, but when I shift to 3rd and give it any amount of gas it falls on its face/backfires and has no power. It will do this in any gear above second, and even the first two gears seem lacking from what it should be. What I need to know is if my combination just doesn't mesh or if I have a timing issue, or anything else you guys can think of. The build is as follows:

400sbc .040over, speed pro 4-valve releif flat top pistons, moly rings, Comp Extreme energy 4x4 cam cl12-243-3 270deg/278deg @ .480/.498 lift, pro comp aluminum heads 2.05/1.60 valve 215cc runner cnc ported 64cc chamber strait plug, comp +.100 push rods .080 thickness, comp 1.5 pro magnum roller rockers, weiand action plus intake, edelbrock 750cfm performer carb, stock fuel pump(running around 5psi), shorty headers, jegs off road y-pipe into 3inch with a thrush vortex muffler, stock HEI

Trans is a NV4500 5-speed and has 3.73 gears with 33x10.5r15 tires.

We had the same setup minus the aluminum heads and pushrods(preveiously it had a set of 92 5.7 heads with 220k miles on them) and the truck ran fine as far as no backfiring it just blew smoke because of the crappy heads. My brother bought the heads with plans of changing to a more agressive cam but then gave me the whole set up for my truck.

I think we have a little over 12deg timing... but this is the first we have messed with aluminum heads and I think I read somewhere that that changes where you would want your timing?

I also know that the carb is probably a bit big for what we have but it was on the setup before with the crap heads and it would at least function without backfiring.

so with that wall of text i'm hoping someone can give me some insight on where to start to get rid of the backfiring and lack of power.

Thanks!
Reply With Quote