Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Very Involved Problem 400sbc
View Single Post
  #31 (permalink)  
Old 12-11-2012, 06:55 PM
89k1500 89k1500 is offline
Registered User
 
Join Date: Dec 2012
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I talked to my brother and he said he didn't change the jets. We want to get a 650 but can't afford it right now(already had the 750 on a shelf). We had a 650(?) Holley given to us so he got a rebuild kit and popped that on(before we got the fuel pump issue squared away) seemed to make it worse. Probably because it was a Holley. =) Haven't tried it since getting good and consistant fuel pressure. It started way harder than the eldelbrock so I'm not overly excited about trying it.

I did however drive the truck to work and I acualy paid close attention to what was happening. First and second go good with no issues than as soon as I shift to 3rd and the RPMs drop below 1500 it backfired under heavy throtle. as soon as I top 1500 it gets better and at 2000 it pulled very well but is still "missing". The same goes with the other gears. anything below 1500 and it falls flat if i give it too much gas. If I lightly roll into the gas it is not nearly as bad and the higher the RPMs the more gas it will take.

So should I get and try larger jets?

Also I want to say we did put heavier weights on the distriburator(before the fuel pump issue) and I hav't messed with timing since. Might be till after CHRISTmas that I can get the lock out plates and jets. I'm not too worried about squeezing out as much power as it can give. I'm just trying to make the thing drivable without falling on its face.

thanks again for the help!
Reply With Quote