volvo s60 gauge on max. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-27-2010, 09:52 AM
Registered User
 
Join Date: Mar 2010
Location: Johannesburg
Posts: 9
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
volvo s60 gauge on max.

I have a Volvo s60 2002 which is experiencing problems with the temperature gauge,the gauge is showing that my engine is overheating ,even when engine has been standing and is stone cold, this is not first time it has happened as this happened 2 weeks ago and it stopped now it has began can anyone help.Also noticed sometimes while driving the gauge is indicating cold when the engine is hot. The car had it's radiator replaced recently after a pothole bump.

    Advertisement

Last edited by gombera; 07-27-2010 at 10:21 AM.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pressure gauge moves to 0 on start 406 bug Engine 27 12-02-2008 04:39 PM
Gas gauge problem Mertz Electrical 2 08-20-2008 01:59 PM
2 oil pressure gauages only 1 works 2000jack Electrical 32 04-20-2006 05:16 PM
Need help with fuel gauge Crazy-J Electrical 3 03-01-2005 11:46 AM
New Gauge Wiring Chadman Electrical 1 04-08-2003 01:25 PM


All times are GMT -6. The time now is 02:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.