Water coming out of exhaust - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 09-10-2010, 01:56 PM
Registered User
Last photo:
Join Date: May 2009
Location: Alberta,Canada
Posts: 91
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Water coming out of exhaust

Hey guys kinda a weird question but when my trucks idling after a cold start it shoots out water outer outta the exhaust. It is a 89 s10 with a 93 sbc 350 TBI. Whats weird is tho after its been running it still does it.... Scared me beacuse I thought it coulda been raw gas but i smelt it (and tasted it) and concluded its not. Any thoughts?

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 09-10-2010, 02:04 PM
DoubleVision's Avatar
Not Considered a Senior Member
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 41
Posts: 10,675
Wiki Edits: 0

Thanks: 15
Thanked 65 Times in 60 Posts
It`s more than likely condensation. Is it running hot? Is coolant disappearing? does the oil appear milky? if not it`s condensation and nothing to worry about. I don`t recommend tasting anything that comes out of a exhaust pipe,, that`s not exactly healthy.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-10-2010, 02:18 PM
Registered User
Last photo:
Join Date: May 2009
Location: Alberta,Canada
Posts: 91
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Haha ya i know. Just did a quick swipe with finger.... IT only runs hot if i let it sit idle for a long time with my twin fans not running.. and coolant wise i top it up when needed... and no milky oil.... If it was that would be head gasket wouldnt it? also when i took my rad cap off to top up the coolant the other day i wiped my finger on the rim underneath the cap and it was black like oil black.. Now that doesnt make sense beacuse the oil was not milky when i changed it the other day.....dirty but not milky
Reply With Quote Quick reply to this message

Recent Engine posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Putting water in the intake??? 79transam Engine 50 01-10-2006 01:23 PM
Exhaust location advice needed. Pic enclosed hemi43 Engine 3 06-29-2005 05:06 PM
Water in Oil Update... TurboS10 Engine 8 06-27-2005 07:55 PM
Turbo`s and Super`s for the intake but what of the exhaust...? Bumpstick Engine 4 05-15-2005 07:44 PM
Water coming out of p/s bolt hole Ed ke6bnl Engine 3 10-29-2003 05:40 PM

All times are GMT -6. The time now is 06:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.