"Weeping" SBC water pump - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-21-2010, 02:51 PM
XNTRCI-T's Avatar
AKA Lee in KC
 
Last photo:
Join Date: Apr 2006
Location: Overland Park, KS
Age: 65
Posts: 530
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
"Weeping" SBC water pump

I have a Weiand aluminum SBC short water pump with maybe 2,000 miles since new. It has begun slowly dripping coolant out the weep hole at the back of the pump... maybe a tablespoon a day right now. Is this an indication of impending failure? Where does the coolant come from when it weeps?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-21-2010, 02:56 PM
T-bucket23's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 56
Posts: 5,084
Wiki Edits: 26

Thanks: 7
Thanked 100 Times in 86 Posts
Yup, you need to change it. The coolant is leaking by the seal and down the shaft. Usually this is the beginning of the end.
__________________
Artificial Intelligence is no match for Natural Stupidity



Chet
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-21-2010, 03:03 PM
cobalt327's Avatar
WFO
 
Last wiki edit: Intake manifold
Last journal entry: 1980 Malibu Wagon
Last photo:
Join Date: Mar 2009
Location: Atlanta
Age: 59
Posts: 5,037
Wiki Edits: 1616

Thanks: 128
Thanked 597 Times in 546 Posts
Quote:
Originally Posted by XNTRCI-T
I have a Weiand aluminum SBC short water pump with maybe 2,000 miles since new. It has begun slowly dripping coolant out the weep hole at the back of the pump... maybe a tablespoon a day right now. Is this an indication of impending failure? Where does the coolant come from when it weeps?
A seal is failing. Seems to happen a lot to pumps that are run w/just water, and nothing else.

Excessive heat (not just hot coolant) can damage seals, a bad finish or too much run out of the shaft can cause seal trouble. Over tightening the belt(s) will do in bearings, but usually not bother the seals.

There are water pump rebuild kits and INFO available, whether the Weiand aluminum pump you have is able to be serviced, I don't know.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OLDS 403 Engine Water Pump bandit79jun Engine 3 02-24-2009 04:30 PM
Shortest SBC water pump Chris Kemp Hotrodding Basics 6 02-10-2009 03:39 PM
High flow water pump for SBC 350 75gmck25 Engine 7 05-22-2007 03:42 PM
Electric water pump, what gpm? New fan? 84Z Engine 4 02-01-2007 05:30 PM
water pump heater hose conenction.... oldcarguy85 Engine 3 04-07-2002 09:34 AM


All times are GMT -6. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.