Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Electrical (http://www.hotrodders.com/forum/electrical/)
-   -   Weird Headlight Issue (http://www.hotrodders.com/forum/weird-headlight-issue-145423.html)

CustomConspiracy 09-21-2008 02:00 PM

Weird Headlight Issue
 
I have a 65 chevy C10 pickup....2 single headlights,,,,Sylvania Halogen bulbs.
The truck shows no signs of ever being swamped pr flooded.....I drove it from California, and drive it every day.
One headlight has nearly 2 inches of water in the bulb!!!!!!! It works, and has been working for 2 years. The other bulb has lots of moisture droplets inside, but not like the other one.
The water has caused the reflector coating to come off but the things still light up.
I'm changing them out finally because they are really dim now but I am very curious about why they are like this and amazed they keep working.

powerrodsmike 09-21-2008 02:13 PM

Crack somewhere...My wife's Mustang had the same bulbs with the same problem, the last time I checked, they still work.

It amazed me that the gas never leaked out...


Later, mikey

pepi 09-21-2008 03:09 PM

not to knock the fords but ............ they have had water in there tail lights starting in 57, I busted a gut the other day as I pulled in behind a ford suv and damn if the tail lights were'nt half full of water. I thought to myself you mean they still have not fixed that problem ................ very funny.
Or just maybe ford is running a bulb test for underwater pool lighting that started in 57.


All times are GMT -6. The time now is 04:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.