Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - The "What Did You Work On Today" thread
View Single Post
  #592 (permalink)  
Old 03-11-2012, 07:23 PM
Bryan59EC's Avatar
Bryan59EC Bryan59EC is offline
Car? Truck? Who Cares
 

Last journal entry: First week of December
Last photo:
Join Date: Jun 2006
Location: San Antonio, Texas
Age: 54
Posts: 2,367
Wiki Edits: 0

Thanks: 1
Thanked 21 Times in 19 Posts
Thursday, I drove my freshly done 66 Elky to an alignment shop.
Had to stop halfway there and disconnect the speedometer.
Thing was just howling.

Friday----pick car up from alignment shop and drove back to the body shop.
When I dropped my car off on Thursday, the shop owner sent me back to the body shop in a customer's Merc--(one of his guys backed into it), so I could retrieve my pickup and go back to work. Picking up the Elky on Friday, the body shop owner called me and asked if I had left yet----he was bringing the repaired Merc back and needed a ride back to the body shop.

Anyway---nice quiet ride--car ran great--and virtually dead silent at cruise.

Saturday---geared up to remove the dash in the 66 again to replace that speedo-----now the car won't start-----have no clue at this point as it had been fine for over 2 months without a battery drain.
Dropped dash----called it a day

Sunday-----back to the hospital to get the strings holding my finger together removed----------still sore (remember the previous incident with the jack stands?). Finger doing well , but I am still a bit hampered by it.
Reply With Quote