Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - The "What Did You Work On Today" thread
View Single Post
  #684 (permalink)  
Old 03-24-2012, 09:13 PM
Bryan59EC's Avatar
Bryan59EC Bryan59EC is offline
Car? Truck? Who Cares
 

Last journal entry: First week of December
Last photo:
Join Date: Jun 2006
Location: San Antonio, Texas
Age: 54
Posts: 2,354
Wiki Edits: 0

Thanks: 1
Thanked 18 Times in 16 Posts
Well,
Been a busy day.

Went to work this morning for a couple of hours and then off to the body shop.
Once at the body shop, I did a couple of small things to the 66 Elky, and then drove it off to the sate safety inspection joint.

Got my safety sticker----put it on the windshield, and then placed my registration sticker on the glass as well.

The 66 is now street legal!!!!!!!

Then---I go home to have a look at my Windstar that decided to get a bit warm
while my son was driving it (I was away for the week---so he had to ride the bus).
Found a ruptured upper radiator hose----no biggie----go to store and get new radiator hoses.
Install hoses and refill radiator-----run car for 20 minutes and everything seems okay.

Have afore mentioned son take the van for a spin and he only got 1/2 mile
before the gauge read too close to "HOT".

New upper hose is collapsed
So---doing some thinking, I check a couple of things.
Found overflow tank hose plugged----fixed that
After the car set for a bit, I added a bit more coolant
and took it for a spin.

Seems to be working fine now----ran about 7 miles with the heater on and another 7 miles with the AC running----temp stayed right in the middle of the gauge.

Appears to be no permanent damage------just had the heads done last year when a head gasket let loose----no overheat either.
Reply With Quote