Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - The "What Did You Work On Today" thread
View Single Post
  #3070 (permalink)  
Old 04-08-2013, 09:49 AM
MARTINSR's Avatar
MARTINSR MARTINSR is offline
Brian Martin,Freelance adviser
 
Last photo:
Join Date: Jun 2004
Location: San francisco bay area
Age: 56
Posts: 13,433
Wiki Edits: 0

Thanks: 1,570
Thanked 1,322 Times in 1,147 Posts
Quote:
Originally Posted by John long View Post
I would think the problems with that little carb would be pretty much limited to dirt, float level. or accelerator pump. What is it doing?

John
I am still not convinced that the accelerator pump is working properly even though I have had it all apart and everything looks fine. This carb's pump doesn't squirt fuel into the intake like every other carb I have ever seen. When you move the linkage on every other carb I know of while looking down into the carb you can see a very distinct SQUIRT of fuel going into the center of the bore. This one the fuel "oozes" out of that little tube you see in the center of the Venturi. That little tube coming up at an angle? It just "oozes" out of it. So I'm not sure that it is working properly. But I have blown out all the passages, I have inspected it to minds end, I see nothing wrong. But then again, I know nothing. I am just looking at it with the common sense God gave me (how much is anyones guess) and looking at the assembly manual (damn these things are nice to have!) with very good drawings and explanations of the the different circuits it all seems proper without actually seeing another carb and how it's accelerator pump would function.

Brian
Reply With Quote