Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - The "What Did You Work On Today" thread
View Single Post
  #3282 (permalink)  
Old 04-26-2013, 06:48 AM
Too Many Projects's Avatar
Too Many Projects Too Many Projects is offline
A few muscle cars & a Corvair
 

Last journal entry: continued
Last photo:
Join Date: Sep 2010
Location: Stillwater, MN
Posts: 441
Wiki Edits: 0

Thanks: 48
Thanked 207 Times in 168 Posts
Quote:
Originally Posted by 496CHEVY3100 View Post
I know you have already cleaned the carburator ,I think twice ,but the lean condition at cruise or soft acceleration sounds like an transfer slot partially plugged ,could be wrong .
Could just be the total crap fuel we have today. Can you still get non-oxygenated fuel in CA ?? That's all I burn in my classic cars and lawn/yard tools with a carburator.....ended all my carb clogging/poor running issues. I still mix a small ratio of Sea Foam with the fuel too.

Wednesday, I put the doors and fenders on the Mustang at work. We got a new battery and I put 3 gallons of gas in it. Trickled a little in the carb and turned the key to see what would happen. The danged thing fired right off. After a couple more carb primings, it ran perfect !!! This from an engine that last ran 9 YEARS ago !!! I did spray a generous shot of Aero Kroil in the cylinders and turned it over a couple dozen times with a socket before I put it back in the body. No leaks in the fuel system either, every piece of which was replaced from the filler neck to the fuel pump.

I dug the head light and grill assembly out of the storage shed to discover the extension housings are junk. Ordered new extension assemblies. They should be here next Monday and then this car will be done and ready for the owner to pick up. The shop owner is pretty pumped that it is really going to leave after all this time....



Last edited by Too Many Projects; 04-26-2013 at 07:04 AM.
Reply With Quote