Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - The "What Did You Work On Today" thread
View Single Post
  #4280 (permalink)  
Old 07-04-2013, 12:29 AM
496CHEVY3100's Avatar
496CHEVY3100 496CHEVY3100 is online now
Appalachian American
 

Last journal entry: ,
Last photo:
Join Date: Jul 2012
Location: Appalachia GA
Posts: 769
Wiki Edits: 0

Thanks: 315
Thanked 241 Times in 210 Posts
somrtimes finding the problem can be hard to find ,and most of the time it is something small overlooked on my red Z28 I have an engine that was originaly built for a dirt circle car so it needs lots of cooling ,it has Air but I cant run it,i put a 160 thermostat alun heads 4 core aluminum radiator with the munual 6 blade flex fan and a 14 in electric fan and a high volume water pump when I put it together to avoid any overheating problems,But that didn't work either, it ran around 210 when driving around 50 mph but if I drove 60 65 it would overheat 230+ in less than 1/2 mile so I could slow down the temp would drop, I tried removing thermostat and using a restrictor like we use in our race cars (a flat disc with a 5/8 hole ) still hot ,tried an adjustable timing retard MSD it helped some I changed to 2 1/2 in exaust helped a little,then a fellow racer told me to see if the shaft driven fan and the electric fan shaft were in line with each other if not they were fighting against each other ,restricting air flow and remove the high volume water pump circulated to fast fpr radiator to cool ,Thet were not so I moved the electric fan down where shafts align and replaced pump with a stock one ,it stopped running hot about 185 at cruise 65-70 with 411 gears but I still cannot turn on air it will run extremely hot in less than 1/4 mile. the previous post is my truck
Attached Thumbnails
Click image for larger version

Name:	1977 Camaro Z28 001.jpg
Views:	31
Size:	341.0 KB
ID:	75416  

Last edited by 496CHEVY3100; 07-04-2013 at 12:35 AM.
Reply With Quote