What would cause a stall on acceleration? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-28-2012, 08:31 AM
Vapor76's Avatar
Registered User
 
Join Date: Apr 2012
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
What would cause a stall on acceleration?

I have a 1986 Chevy C10 pickup with a 305ci engine and TH350 transmission. The engine has been fitted with an Eddlebrock 650cfm carb. The engine starts without any trouble. However, when I accelerate while pulling out of the driveway, the engine stalls leaving me stranded in the roadway. The problem eventually goes away after the engine warms up. Any thoughts?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-28-2012, 10:17 AM
sideshowbh's Avatar
Registered User
 
Join Date: Apr 2012
Location: East Texas
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Is the carb fitted with a choke?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-28-2012, 12:01 PM
Jim Rockford's Avatar
World Famous VF-14
 

Last journal entry: Cleaned it up...
Last photo:
Join Date: Dec 2008
Location: Virginia
Age: 43
Posts: 411
Wiki Edits: 0

Thanks: 10
Thanked 0 Times in 0 Posts
prolly could use a little bigger pump shot...
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
acceleration straightpipe Engine 2 07-08-2010 02:23 PM
acceleration ****************** pepi Hotrodders' Lounge 8 06-30-2008 10:42 PM
High stall or low stall neverending Transmission - Rearend 12 02-26-2007 09:28 AM
acceleration Dbodily Hotrodders' Lounge 21 10-24-2005 09:33 AM
Stumbles throughout acceleration FASTMONTE Engine 5 11-13-2004 07:38 PM


All times are GMT -6. The time now is 12:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.