Why did this happen? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-21-2012, 09:09 AM
EazyDuzIt102's Avatar
1965 Impala SS Convertible
 
Last photo:
Join Date: May 2003
Location: Antioch IL
Age: 27
Posts: 330
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Why did this happen?

Ok I was driving my Impala last week after having a front power disc brake conversion installed. While I was driving going about 60mph, the car suddenly jerked to the left and pulled me into the lane next to me. I lost complete control of the car and luckily I was able to get the car off the road without hurting myself or someone else. After taking a look at the driver side brakes I seen brake fluid running down the back of the rotor and also noticed that there are some parts of the brake that is rubbing on the rotor that shouldnt be. I hope its easy to see in the pictures but my question is, how did this happen because I have never seen this?
Attached Thumbnails
Click image for larger version

Name:	20120916_140503.jpg
Views:	127
Size:	238.2 KB
ID:	67991   Click image for larger version

Name:	20120916_140455.jpg
Views:	128
Size:	220.9 KB
ID:	67992  

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-21-2012, 08:24 PM
RWENUTS's Avatar
Registered User
 
Last photo:
Join Date: Nov 2011
Location: Nanaimo, BC, Canada
Age: 63
Posts: 1,989
Wiki Edits: 0

Thanks: 59
Thanked 212 Times in 200 Posts
Maybe the caliper bracket was installed wrong or not torqued properly.
Looks bent or out of alignment.
After you check the drivers side then look at the passenger side too!
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-21-2012, 08:36 PM
Registered User
 
Last wiki edit: General Motors transmissions Last photo:
Join Date: Mar 2006
Location: near Yellowstone park
Posts: 4,340
Wiki Edits: 27

Thanks: 12
Thanked 257 Times in 241 Posts
take it apart

It looks like the caliper bracket bolt does not align with the casting, Did a bolt shear off?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-22-2012, 05:18 AM
MARTINSR's Avatar
Brian Martin,Freelance adviser
 
Last photo:
Join Date: Jun 2004
Location: San francisco bay area
Age: 55
Posts: 13,202
Wiki Edits: 0

Thanks: 1,338
Thanked 1,168 Times in 1,030 Posts
How about the wheel bearing? if it was all mounted properly and wasn't hitting when installed maybe the rotor is what has moved and not the caliper?

Brian
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 09-22-2012, 05:55 AM
Jimbo17's Avatar
Nostalgic Racing Decals
 
Last photo:
Join Date: Oct 2006
Location: Florida
Posts: 152
Wiki Edits: 0

Thanks: 0
Thanked 13 Times in 10 Posts
I am also thinking wheel bearing!!!!!!!!!

I had a car once doing something very similar and when I got the car stopped and started checking things I could figure out what was going on a first.

Did you still have plenty of brake petal when this happened of did it go to the floor?

Jimbo
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 09-22-2012, 08:33 AM
EazyDuzIt102's Avatar
1965 Impala SS Convertible
 
Last photo:
Join Date: May 2003
Location: Antioch IL
Age: 27
Posts: 330
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
The feel of the pedal didnt really change. I havent pulled everything completely apart yet but I was thinking maybe wheel bearing too. Everything in this conversion kit was brand new from the box. This was the first time driving the car with these brakes
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How did it happen for you? rossco Hotrodders' Lounge 32 06-20-2007 09:03 PM
should this happen? budynabuick Electrical 17 11-28-2006 04:35 PM
What Would Happen? budynabuick Engine 4 08-12-2006 09:12 AM
how would this happen?!?! red_rider52 Transmission - Rearend 12 01-18-2005 09:23 AM
Anyone had this happen??? ets1945 Hotrodders' Lounge 12 03-31-2004 08:40 PM


All times are GMT -6. The time now is 02:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.