Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Wideband afr, any preferences on brand?
View Single Post
  #10 (permalink)  
Old 09-18-2011, 08:03 PM
bubbahotep's Avatar
bubbahotep bubbahotep is offline
Registered User
 
Last photo:
Join Date: Aug 2008
Location: NYC
Age: 42
Posts: 487
Wiki Edits: 0

Thanks: 1
Thanked 1 Time in 1 Post
I got the AEM wideband installed and didnt want to make another post with basic questions.

I drove the car today, couldnt do any WOT, but I got on it pretty hard and had the speedo pinned in no time (85mph tops). Without a datalogger I watched the display to memorize the average readings

I idle in gear at 13.5 at about 1000 rpm on the 383 stroker. A heavy acceleration from a standstill or rolling at 20mph gives me a solid 12.2-12.5 average reading. Thats with the trans dropping down a gear (auto trans) and the secondaries opening. It seems to stay about 12.2 as it shifts up through the gears.

Cruise in 4th gear at 2500-3000rpm is 15.8 with no load at all (My understanding is that this is way lean)

Where Im wrong correct me but I thought I need 12.5-13 overall as a good AFR. So at cruise Im too lean, I have holley 73 primary jets and was going to increase those and then readjust my idle screws accordingly?? My existing powervalve is a 5.5 based on my 11hg idle vacuum, its a vac secondary carb with the yellow spring. 3310-c carb

Below is my original 86 O2 sensor which has been plugging the bung hole since the early 90's. I couldnt get this one to work for some reason.

Reply With Quote