will it work - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-29-2008, 09:40 AM
Registered User
 
Join Date: Oct 2008
Location: Amarillo, TX
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
will it work

I have a 88 camaro that came stock with a 2.8 MPI and i was wondering if a 305 TBI from a 93 GMC will work with a ECM swap or would I have to change the harness also? i was told i could change the pcm/ecm but i got to looking at the wiring harness and it is set up for six injectors and not two is there a pig tail or is there another harness piece that will hook up to the existing harness? Or do i need to pull both pcm's and harnesses?

    Advertisement

Last edited by briced; 10-29-2008 at 10:25 AM. Reason: its mine
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-29-2008, 10:13 AM
richard stewart 3rd's Avatar
Registered User
 

Last journal entry: 351W rebuild
Last photo:
Join Date: Jan 2006
Location: tremont, pa.
Age: 70
Posts: 2,218
Wiki Edits: 0

Thanks: 14
Thanked 15 Times in 14 Posts
Hi
The 2.8 is a V6, six cylinders
the 5.L is a V8, eight cylinders
If it can be don, I don't know how to do it.
Good luck,
Rich
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-29-2008, 10:25 AM
1931 steve's Avatar
Hotrodders.com Moderator
 
Last wiki edit: How to rebuild an engine Last photo:
Join Date: Nov 2004
Location: Michigan
Age: 43
Posts: 1,207
Wiki Edits: 4

Thanks: 0
Thanked 0 Times in 0 Posts
You will need to change the wire harness also, everything is different. You can buy a aftermarket harness that makes things easier, but you can also use the factory harness, just need to sort through what you need in that (OEM) harness.

Steve
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"a little over" turns into $4500 over for paint job bullheimer Body - Exterior 128 02-06-2006 08:57 AM
89 honda accord, headlights wont work...and... Rubberman2003 Electrical 6 02-10-2005 05:26 AM
Work. coldknock Hotrodders' Lounge 6 11-21-2004 04:57 PM
Stuff I work on at work :) esears Hotrodders' Lounge 6 09-29-2003 01:08 PM
Ever work on the impossible? johnsongrass1 Hotrodders' Lounge 16 08-20-2003 01:59 PM


All times are GMT -6. The time now is 03:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.